Closed Bug 1336274 Opened 4 years ago Closed 4 years ago

Intermittent dom/animation/test/chrome/test_restyles.html | application crashed [@ mozilla::layers::ForEachNode<mozilla::layers::ForwardIterator, mozilla::layers::Layer*, mozilla::layers::Layer::StartPendingAnimations(const mozilla::TimeStamp&)::]

Categories

(Core :: DOM: Animation, defect)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1334583

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: crash, intermittent-failure, Whiteboard: [stockwell fixed])

I guess this crash is bug 1334583.
See Also: → 1334583
I thought initially fix for bug 1333539 raised the probability of this crash, but the fix had not yet merged into inbound at the revision in comment 0.

https://hg.mozilla.org/integration/mozilla-inbound/file/86de6a5ecbe550ffe5cbd49c7cc4f40c2576e848/dom/animation/Animation.h#l279
Severity: normal → critical
Keywords: crash
OS: Unspecified → Android
Hardware: Unspecified → ARM
(In reply to Hiroyuki Ikezoe (:hiro) from comment #1)
> I guess this crash is bug 1334583.

That seems right. If you look at the logcats for these failures, you can see the assertion:

https://treeherder.mozilla.org/logviewer.html#?repo=try&job_id=86430564&lineNumber=2074

https://public-artifacts.taskcluster.net/KGxqeiKsQS689iNrhB6gfw/0/public/test_info//logcat-emulator-5554.log

03-25 10:40:10.932   792   807 I GeckoDump: ⰲ겿{"action":"log","time":1490463610934,"thread":null,"pid":null,"source":"mochitest","level":"INFO","message":"SpawnTask.js | Entering test change_duration_and_currenttime","js_source":"TestRunner.js"}ⰲ겿
03-25 10:40:11.321   792   807 I GeckoDump: ⰲ겿{"action":"test_status","time":1490463611321,"thread":null,"pid":null,"source":"mochitest","test":"chrome://mochitests/content/chrome/dom/animation/test/chrome/test_restyles.html","subtest":"undefined assertion name","status":"PASS","js_source":"TestRunner.js"}ⰲ겿
03-25 10:40:11.341   792   807 I GeckoDump: ⰲ겿{"action":"test_status","time":1490463611333,"thread":null,"pid":null,"source":"mochitest","test":"chrome://mochitests/content/chrome/dom/animation/test/chrome/test_restyles.html","subtest":"undefined assertion name","status":"PASS","js_source":"TestRunner.js"}ⰲ겿
03-25 10:40:11.672   792   807 F MOZ_Assert: Assertion failure: !IsNull() (Cannot compute with a null value), at /home/worker/workspace/build/src/obj-firefox/dist/include/mozilla/TimeStamp.h:527


Just a reminder, if we are not going to make progress on bug 1334583, we can effectively avoid these failures by skipping on Android Debug.
I am suspecting the reason why failure frequency of this raised in these days is the same as bug 1351042.
The frequency of this failure increased today or yesterday (now about a half of all runs on autoland in the last 12 hours). Please take a look.
Flags: needinfo?(bbirtles)
possibly :gbrown would know if there was a tooling change.

also I see an assert in the failure messages:
04-30 00:38:53.124 F/MOZ_Assert( 805): Assertion failure: !IsNull() (Cannot compute with a null value), at /home/worker/workspace/build/src/obj-firefox/dist/include/mozilla/TimeStamp.h:527

this is right in the mix of when we are failing the test case- possibly related or just a side effect after the crash?
Whiteboard: [stockwell needswork]
I don't know of any recent Android tooling change.

Based on :hiro's earlier comments, I'd say we should push for a fix in bug 1334583 or skip this test on Android Debug.
I'm going to work on a fix for bug 1334583 today. If I don't get something ready by the end of the day let's just skip this test on Android debug.
I didn't quite finish fixing bug 1334583 today so I'll finish it off tomorrow. Feel free to disable to test if it gets too annoying in the meantime.
Flags: needinfo?(bbirtles)
Just to update here. I have patches up for review for bug 1334583 and a couple of dependent bugs. An initial try run for those looks promising.
overall this seems fixed
Whiteboard: [stockwell needswork] → [stockwell fixed]
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334583
You need to log in before you can comment on or make changes to this bug.