Closed Bug 1336291 Opened 3 years ago Closed 3 years ago

Lots of "TypeError: this._browsers is null: _getBrowserRefs@resource://app/modules/NewTabWebChannel.jsm:149" logspam during browser_remotenewtab_pageloads.js

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 54
Tracking Status
firefox52 --- fixed
firefox-esr52 --- fixed
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: RyanVM, Assigned: mak)

References

Details

Attachments

(1 file)

This is a really spammy message while this test is running. Affects all current branches.
https://treeherder.mozilla.org/logviewer.html#?job_id=74137204&repo=mozilla-beta&lineNumber=3516

Looking at the blame of the file, I'm not even sure who's around to look at this anymore. Kate, can you maybe take a look or suggest someone else who might?
Flags: needinfo?(khudson)
Summary: Lots of "ypeError: this._browsers is null: _getBrowserRefs@resource://app/modules/NewTabWebChannel.jsm:149" logspam during browser_remotenewtab_pageloads.js → Lots of "TypeError: this._browsers is null: _getBrowserRefs@resource://app/modules/NewTabWebChannel.jsm:149" logspam during browser_remotenewtab_pageloads.js
Regression from bug 1320481.

This is problematic because the error can occur so often that other failures aren't part of the error summary for a job on treeherder anymore and one has to open and search the raw log.
Blocks: 1320481
Flags: needinfo?(khudson) → needinfo?(mak77)
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Flags: needinfo?(mak77)
The problem is that frecency changes can send notifications quite late on shutdown, new tab receives the notification and tries to handle it.
This is mostly a stopgap fix, I don't think we should go much further honestly.
Comment on attachment 8834048 [details]
Bug 1336291 - Lots of 'TypeError: this._browsers is null' browser_remotenewtab_pageloads.js.

https://reviewboard.mozilla.org/r/110146/#review111192
Attachment #8834048 - Flags: review?(felipc) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/ec06d5263eb3
Lots of 'TypeError: this._browsers is null' browser_remotenewtab_pageloads.js. r=Felipe
https://hg.mozilla.org/mozilla-central/rev/ec06d5263eb3
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Confirmed that the spam is gone. Please request Aurora/Beta approval on this when you get a chance.
Status: RESOLVED → VERIFIED
Flags: needinfo?(mak77)
Comment on attachment 8834048 [details]
Bug 1336291 - Lots of 'TypeError: this._browsers is null' browser_remotenewtab_pageloads.js.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1320481 
[User impact if declined]: No users impact, but lots of spam in test runs that impacts sheriffs and developers
[Is this code covered by automated tests?]: not this specific fix
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple early return
[String changes made/needed]: none
Flags: needinfo?(mak77)
Attachment #8834048 - Flags: approval-mozilla-beta?
Attachment #8834048 - Flags: approval-mozilla-aurora?
Comment on attachment 8834048 [details]
Bug 1336291 - Lots of 'TypeError: this._browsers is null' browser_remotenewtab_pageloads.js.

early return to fix test log spam, aurora53+, beta52+
Attachment #8834048 - Flags: approval-mozilla-beta?
Attachment #8834048 - Flags: approval-mozilla-beta+
Attachment #8834048 - Flags: approval-mozilla-aurora?
Attachment #8834048 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.