Clicking on link in MS Outlook causes "Locate Link Browser" dialog

VERIFIED DUPLICATE of bug 59078

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 59078
16 years ago
13 years ago

People

(Reporter: markh, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Set Mozilla as the default browser using the Mozilla preferences. Integration
with Windows seems to work quite well - clicking a HTML file from explorer or
most applications correctly loads Mozilla.

However, it does not work correctly when using Outlook as a mail client. 
Clicking on a link in an outlook message will cause Mozilla to load correctly,
but a dialog with "Locate Link Browser" is also displayed.  This dialog is
asking you to locate a .EXE file.  If you cancel this dialog it will be
displayed next time you select a link.  If you select a .EXE file, then the
dialog will not be displayed again.

It turns out the problem is a preference inside MS Outlooks part of the
registry.  Specifically, the registry key:

HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Preferences

Has a subkey named "InternetBrowserPath".  Note that this is for Office 2000 -
presumably Office XP uses a "10.0" key :(

If this key is empty or invalid, the "Locate Link Browser" dialog will be
displayed.  The EXE you select will be written back to this registry.

I think a patch that carefully checks for this key and tries to update it to the
mozilla EXE as the same time we set the other registry entries would not be too
hard.  Should we try and handle this situation?
(Reporter)

Comment 1

16 years ago
hrm - it appears this can be treated as a dupe of bug 59078.

If the DDE settings described in that bug are removed, then Outlook does seem to
work fine, and ignores the "InternetBrowserPath" entry.

*** This bug has been marked as a duplicate of 59078 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.