Option to activate Firebug by default on new tabs?

RESOLVED DUPLICATE of bug 1284012

Status

()

Firefox
Developer Tools
RESOLVED DUPLICATE of bug 1284012
a year ago
a year ago

People

(Reporter: Rockie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

Hi!

I used Firebug and now it has been updated to new version(as I understand it is now Firefox DevTools). Earlier if I was using Firebug and opened new tab - Firebug was already activated there (think this behaviour was related with extensions.firebug.allPagesActivation option in about:config). 

FireFox version is 51.0.1 (32-bit)
Firebug 2.0.18 (not sure, think it is now "Firefox DevTools")


Actual results:

Now if I have DevTools activated on my tab, and I open another page in new tab - there is no DevTools Activated. I need to press F12 every time. 


Expected results:

Can I have setting to activate Firebug by default for new tabs? "allPagesActivation" option in about:config. Now I suggest it doesn't work.

here is a link to my post on stackoverflow:
http://stackoverflow.com/questions/42021934/enable-firebug-on-new-opened-tabs-by-default-if-it-was-enabled-before
here is another related topic:
http://stackoverflow.com/questions/5127776/is-there-any-way-to-start-automatically-the-firebug-inspector-after-starting-fir

Best regards,  
Gennady
This is already requested in bug 1284012.

(In reply to Rockie from comment #0)
> Firebug 2.0.18 (not sure, think it is now "Firefox DevTools")

For clarification. The Firefox DevTools are *not* Firebug. They are developed by Mozilla and are built into Firefox for several years now, while Firebug is an extension, which was developed by the Firebug Working Group (which consisted mainly of volunteer developers). The development of Firebug is now discontinued, mainly due to multi-process Firefox. You can read more about that on https://hacks.mozilla.org/2016/12/firebug-lives-on-in-firefox-devtools/.

Sebastian
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1284012
Component: Activity Streams: General → Developer Tools
(Reporter)

Comment 2

a year ago
Ah, Ok)

Thank You Sebastian!

Best regards,
Gennady
You need to log in before you can comment on or make changes to this bug.