Cannot have Firefox and Firefox Developer Edition open at the same time

UNCONFIRMED
Unassigned

Status

()

defect
UNCONFIRMED
3 years ago
4 months ago

People

(Reporter: KohlyKohl, Unassigned, NeedInfo)

Tracking

53 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170203004018

Steps to reproduce:

I updated Firefox Developer edition today to 53.0a2 (2017-02-03) (64-bit).
Firefox is the latest stable 51.0.1.0 (64-bit)

Previously, I was able to open Firefox and Firefox Developer Edition together.


Actual results:

I receive a popup stating that, "Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window."

I checked the .ini file and the settings in there are correct as per:
Bug 1262036 - "Allow Firefox Developer Edition and Firefox to run at the same time" option does nothing 

I also unchecked the option to allow them to run at the same time and restarted. I then checked the option and restarted. This had to affect.


Expected results:

Firefox and Firefox Developer Edition run along side each other.
Component: Untriaged → Preferences
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
It's easy to fix in general. Say Firefox Release is your default browser, just define your current profile as default in the profile manager (firefox.exe -p).
For Firefox DE, open the properties of its shortcut and modify the path to add '-p "profile_for_DE" -no-remote'.

Like that, every time you're using Firefox with your current profile, you can start Firefox DE with another profile (here called "profile_for_DE") at the same time.
Flags: needinfo?(KohlyKohl)
Even if it's easy to fix, Firefox DE should by default not require anyone to create a profile just for the sake of running Firefox release, in my opinion.

Both Firefox versions should be considered completely separate, and should not be using the same Firefox processes at all.
I'm running Release 54 and Developer edition 55 and this still seems to be an issue on Windows 7. Not sure about 8/8.1/10
Seeing same issue with Firefox Developer Edition 56.0b9 (64-bit) and Firefox 52.3.0 ESR (64-bit) on Windows 10 Pro

Still having this issue on Mac. Both versions are up to date. I have tried toggling the DE preference to have both running and it still errors.

You need to log in before you can comment on or make changes to this bug.