Xerox Workstation 7225 with ID Code

RESOLVED DUPLICATE of bug 1317801

Status

()

RESOLVED DUPLICATE of bug 1317801
2 years ago
2 years ago

People

(Reporter: FRusso, Assigned: haik)

Tracking

51 Branch
Unspecified
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; Touch; .NET4.0C; .NET4.0E; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729; Tablet PC 2.0; InfoPath.2; ASU2JS; rv:11.0) like Gecko

Steps to reproduce:

From MAC Laptop (10.12) and Firefox 51.0 (currently)
Xerox Workstation 7225 with ID Code account. It have been set up in preference profile.

From any sites, I print or Ctrl-P it.(it don't matter where you visit sites)


Actual results:

Xerox Workstation 7225 returned error that ID code is invalided.


Expected results:

It should be print as normal. I have no problem on and before version 49.

Seem Version 50/51 have "remove" ID Code from Printer Preference.

Is someone changed Printer code?
(Reporter)

Updated

2 years ago
OS: Unspecified → Mac OS X
(Reporter)

Comment 1

2 years ago
Add note: If I used Safari or Google Chrome, It print out as normal without any problem.
Component: Untriaged → Printing: Setup
Product: Firefox → Core
haik - sounds like this might be a similar cause to those other e10s printing problems.
Flags: needinfo?(haftandilian)
(Assignee)

Comment 3

2 years ago
Will have to look into this some more. It sounds like the ID Code is something set in the Xerox driver settings, but is no longer being sent to the printer. Perhaps the printer-specific part of the page setup settings are getting lost. That might also explain Bug 1336211 regarding the paper tray.

FRusso, thanks for reporting the bug. Could you attach a screenshot of how you set the ID Code in the printer settings?
Flags: needinfo?(FRusso)
(Reporter)

Comment 4

2 years ago
Created attachment 8839517 [details]
Note_1.jpg

Xerox Preference setup #1
(Reporter)

Comment 5

2 years ago
Hmm. I can't add more than one picture. Ok, Anyway!

There is very interest. I think I found a possible bug within printer code in Firefox. I will show what I did step by step.

1) First thing is I cleared ALL preferences in both User and System Library Folders. (Delete Mozilla and Firefox Folders, etc.) Firefox will write new preferences when I open it for "First-time"

2) You *CAN* print it from any sites with ID code without ANY problems. That is weird, right?

3) ***BUT*** When you quit Firefox Apps. Then open and print it again, Printer returned ID Code is invalid!

I think there is "happen" between "first-time open firefox app" and "close/open firefox app" seem if it have changed things after it closed.

I hope it help for you to track that darn bug. It MAY effect happen to other printers with ID Code or so.

Comment 6

2 years ago
We are having very similar problems here at the school I work for.  We have Konica-Minolta copiers/printers.  We have account codes setup for each of our users.  We are a Mac environment.  Account codes worked perfectly in FireFox 48.0.2 and older. Any versions of FireFox after that fail to print.  When looking at the copier/printer logs it shows a print job arrived but no account code information was sent with the print job so the print job gets rejected every time.  All other web browsers like Safari and Chrome print fine.  Applications like Word or Excel print without any issue.  Just FireFox for Mac higher than 48.0.2 fail.  For some reason Firefox has stopped sending the user's account track code with the print job.  I've tested this MacOS X 10.9.5, 10.11.6, and 10.12.3 operating systems and they all fail.  It doesn't seem to be operating system specific.  I've tried several older versions of our Konica-Minolta BizHub 554e and 454e drivers and older versions of the driver does not make our users able to print from newer versions of Firefox.  The only thing that does make them print from Firefox is installing version 48.0.2 or older.  Anything newer the account track code never gets sent so the copier/printer just ignore the print job.  Thank you for listening.  Please fix this Firefox printing bug.

Comment 7

2 years ago
Created attachment 8839614 [details]
FireFox Print Window.png
(Assignee)

Comment 8

2 years ago
(In reply to Scott Jelsma from comment #6)
> We are having very similar problems here at the school I work for.  We have
> Konica-Minolta copiers/printers.  We have account codes setup for each of
> our users.  We are a Mac environment.  Account codes worked perfectly in
> FireFox 48.0.2 and older. Any versions of FireFox after that fail to print. 
> When looking at the copier/printer logs it shows a print job arrived but no
> account code information was sent with the print job so the print job gets
> rejected every time.  All other web browsers like Safari and Chrome print
> fine.  Applications like Word or Excel print without any issue.  Just
> FireFox for Mac higher than 48.0.2 fail.  For some reason Firefox has
> stopped sending the user's account track code with the print job.  I've
> tested this MacOS X 10.9.5, 10.11.6, and 10.12.3 operating systems and they
> all fail.  It doesn't seem to be operating system specific.  I've tried
> several older versions of our Konica-Minolta BizHub 554e and 454e drivers
> and older versions of the driver does not make our users able to print from
> newer versions of Firefox.  The only thing that does make them print from
> Firefox is installing version 48.0.2 or older.  Anything newer the account
> track code never gets sent so the copier/printer just ignore the print job. 
> Thank you for listening.  Please fix this Firefox printing bug.

Scott, thanks for the detailed info. Would it be possible for you to test with Firefox Developer Edition build 53? Link below. That release has some printing-related changes that aren't in regular Firefox yet. It won't replace the Firefox you have installed.

  https://www.mozilla.org/en-US/firefox/developer/all/

It sounds like the problem started happening with Firefox 49 which was when multi-process Firefox was first enabled for many users and that caused some printing issues.

Build 53 (actually build 52+) includes some low level changes to how print settings are handled (for remote printing). Though it's better to test with 53/DeveloperEdition because 52/Beta doesn't always enable multi-process mode.

Thanks.
Flags: needinfo?(haftandilian) → needinfo?(scott)
(Assignee)

Comment 9

2 years ago
(In reply to FRusso from comment #5)
> Hmm. I can't add more than one picture. Ok, Anyway!
> 
> There is very interest. I think I found a possible bug within printer code
> in Firefox. I will show what I did step by step.
> 
> 1) First thing is I cleared ALL preferences in both User and System Library
> Folders. (Delete Mozilla and Firefox Folders, etc.) Firefox will write new
> preferences when I open it for "First-time"
> 
> 2) You *CAN* print it from any sites with ID code without ANY problems. That
> is weird, right?
> 
> 3) ***BUT*** When you quit Firefox Apps. Then open and print it again,
> Printer returned ID Code is invalid!
> 
> I think there is "happen" between "first-time open firefox app" and
> "close/open firefox app" seem if it have changed things after it closed.
> 
> I hope it help for you to track that darn bug. It MAY effect happen to other
> printers with ID Code or so.

That helps. There's a good chance this is fixed in a newer release. (See above comment). Would you be able to test with Firefox Developer Edition (build 53) to see if the problem is fixed in that release? Link below.

  https://www.mozilla.org/en-US/firefox/developer/all/

Thanks
(Assignee)

Updated

2 years ago
See Also: → bug 1336211
(Assignee)

Updated

2 years ago
Assignee: nobody → haftandilian

Comment 10

2 years ago
Haik:

Yes this Firefox Developer Edition build 53 does fix the account track printing issue we are experiencing.

I’m assuming we won’t see this fix in 51.0.2 or any version of FireFox 52 but will appear in version 53.0 when it is released?

Thank you….

Scott
(Assignee)

Comment 11

2 years ago
(In reply to Scott Jelsma from comment #10)
> Haik:
> 
> Yes this Firefox Developer Edition build 53 does fix the account track
> printing issue we are experiencing.

That's great!
 
> I’m assuming we won’t see this fix in 51.0.2 or any version of FireFox 52
> but will appear in version 53.0 when it is released?

This should already be fixed in build 52 as well which is scheduled to release on March 7th. This bug wouldn't meet the criteria to try to get an update into 51 given that 52 is so close to release. If for some unexpected reason you still see this in 52, we can re-open the bug and figure out what's happening.

I asked you to test on 53 because Firefox Beta (52 right now) is setup to not always enable multi-process (aka e10s). If you happened to get multi-process turned off, then the test wouldn't tell me if the problem was really fixed. Because multi-process mode is what is triggering this. For more details, Beta is in experiment mode so some users get multi-process and some don't. This allows us to compare crash rates and make sure multi-process works as well as single-process. If you open about:support, the "Multiprocess Windows" value tells you if multi-process is enabled.

And you can get Beta here if you want to try it.

  https://www.mozilla.org/en-US/firefox/beta/all/
Flags: needinfo?(scott)
(Assignee)

Comment 12

2 years ago
Closing as a dupe of bug 1317801 because all signs point to this being fixed by the enabling of remote printing which is on for build 52. Find more of an explanation in my comment here https://bugzilla.mozilla.org/show_bug.cgi?id=1336211#c7 which is a similar bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1317801
(Reporter)

Comment 13

2 years ago
Firefox 52.0 Beta for Mac computers. (It was updated when i clicked about firefox.) I tested it and it working as it should be. Included "wrong" code ID test. It perfected working. Why is multi-process mode need be in Firefox 49 and above? What it is for?

Anyway, Maybe you should drop multi-process codes in Mac in future. (or disable by default.) I don't know if it has same problem for Windows or Linux.

I just wonder. Can you give me how to disable multi-process mode in Firefox 51.0? Just want to verify things. If it working, then we would know multi-process is problem with printer with ID code.
(Assignee)

Comment 14

2 years ago
(In reply to FRusso from comment #13)
> Firefox 52.0 Beta for Mac computers. (It was updated when i clicked about
> firefox.) I tested it and it working as it should be. Included "wrong" code
> ID test. It perfected working. Why is multi-process mode need be in Firefox
> 49 and above? What it is for?

Thanks for testing that. Multi-process is a big project to make Firefox faster and more secure. This printing bug just happened to be introduced when we switched to multi-process and is now fixed in build 52 scheduled to be released in a week or so (March 7th). The project is called e10s and you can find lots of information online about it.

> Anyway, Maybe you should drop multi-process codes in Mac in future. (or
> disable by default.) I don't know if it has same problem for Windows or
> Linux.

This was a Mac-specific problem.

> I just wonder. Can you give me how to disable multi-process mode in Firefox
> 51.0? Just want to verify things. If it working, then we would know
> multi-process is problem with printer with ID code.

If you want to disable it for testing, you can do so by going into about:support and setting browser.tabs.remote.autostart to false and then restarting the browser. I don't recommend disabling it though. Remember to change that back to true when you're done testing.
Flags: needinfo?(FRusso)
(Reporter)

Comment 15

2 years ago
Thank you for answers. 

I can confirmed that Firefox 51.0.1 or below printing is working when I setted browser.tabs.remote.autostart.2 to false in prefs.js.

Of course Error ID Code if browser.tabs.autostart.2 setted to true.

Ok. That is it. I will looking forward release 52
You need to log in before you can comment on or make changes to this bug.