Open Bug 1336485 Opened 3 years ago Updated 2 years ago

Add option to copy request with post parameters as URL

Categories

(DevTools :: Netmonitor, enhancement, P2)

51 Branch
enhancement

Tracking

(Not tracked)

REOPENED

People

(Reporter: steve, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170118123726

Steps to reproduce:

In the network tab Firebug had a right-click option to copy the POST request as a URL. I forget the actual option wording but it combined the URL query string with the POST data to create a single URL.


Actual results:

This is not available as far as I can tell.


Expected results:

Add an option to copy request as URL.
Severity: normal → enhancement
Component: Untriaged → Developer Tools: Netmonitor
Summary: Feature Request: Copy request as URL → Add option to copy request with post parameters as URL
I think its the same as Bug 1031956 - "Copy as cURL" is building GET when it should be POST

If it's not, feel free to reopen this bug again
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1031956
I don't believe this is the same Bug 1031956. In that bug the cURL generated for a POST is incorrectly being generated as a GET. This one is more a feature request than a bug in that I would like to see the POST request turned into a URL or URI (sorry, I get the two mixed up). Example:

POST to https://xyz.com/form.htm?action=signup where form might contain firstname=steve, lastname=me

Copy as URL would create the following and put it in the clibboard:

https://https://xyz.com/form.htm?action=signup&firstname=steve&lastname=me

This feature was in the FireBug and unfortunately I got addicted to it.
Thanks steve, the comment 2 description is more clear and looks like a helpful feature
Status: RESOLVED → REOPENED
Ever confirmed: true
Priority: -- → P2
Resolution: DUPLICATE → ---
I missed this feature so badly (for development) that I switched to Firefox ESR and disabled mutli-process so I could continue using Firebug.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.