make context (right-click) menu item "copy" copy link title

VERIFIED WONTFIX

Status

SeaMonkey
UI Design
--
enhancement
VERIFIED WONTFIX
16 years ago
8 years ago

People

(Reporter: Michael Wardle, Assigned: Matthew Paul Thomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
build 2002031104 win32

If I right click on a hyperlink, I get the option to "Copy Link Address",
however the "Copy" option is grayed out.

It would be really neat if the "Copy" action copied the link title (the bits
between the greater and less than signs in the tag).

For instance, given this link (using pre tag to stop this being rendered):
<pre>
<a href="http://www.mozilla.org">The Mozilla Organization</a>
</pre>

right-clicking on the hyperlink and selecting "Copy" should place "The Mozilla
Organization" in the clipboard buffer.

Just a wish.

Comment 1

15 years ago
"Copy" is never an option unless you have selected some text.  You can select
the link text and choose copy from the right-click menu.  The behavior you
describe (right-click copy with no selection) would be confusing to many users.

<michael.wardle@adacel.com> Please mark this bug INVALID or WONTFIX

Comment 2

15 years ago
Michael: as already stated, "Copy" needs something selected. Another possibility
might be the desire for a context menu entry called "Copy Link Title" (or
similar), comparable to what you get with e-mail adresses.
But probably this entry would be regarded as not worth the further bloating of
menus because one can simply highlight the Link Title and then right-click->Copy.

So please either resolve this bug as WONTFIX or change this bug's summary to
reflect the longer menu entry, depending on what you think is best.

Comment 3

15 years ago
*** Bug 121442 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

15 years ago
Previous comments suggest this is something that can not or will not be done.
Status -> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 5

15 years ago
*** Bug 172000 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
so there is no solution to how painful it is to copy text inside a link?... (I
filed a dupe of this earlier this week)

Comment 7

15 years ago
keithkml: what on earth is painful about clicking on a link and moving the mouse 
slightly while holding the mouse button pressed to get the link text selected?
Afterwards just press Ctrl-C (on Win) or use the context menu to copy the 
selected text.
You are still free to open a new bug with a more appropriate description 
(concerning the potential menu entry; see the comments above).

But personally I think that an additional menu entry for a thing that is as 
rarely used (IMO) and as easily to do by other means would be a waste of screen 
estate and make it more difficult to find the desired menu entry (because the 
menu would get larger - and there are surely many other people who would like to 
see various other entries in the context menu...)

Comment 8

15 years ago
um, here on linux, dragging anywhere on a link drags the link.. I don't want to
have to drag the link to copy. it doesn't make sense.

Comment 9

15 years ago
------- Additional Comments From durbacher@gmx.de  2002-10-02 13:30 -------
> keithkml: what on earth is painful about clicking on a link and moving the
mouse                       
> slightly while holding the mouse button pressed to get the link text selected?

It doesn't work; at least not on my PowerBook. When I do as you describe, I get
a menu come up, which does not have an option to select the text, which is what
this bug is asking for.

> Afterwards just press Ctrl-C (on Win) or use the context menu to copy the
> selected text. 

That might be OK, if it worked as you describe, but it doesn't for me (build
2002100208).

> You are still free to open a new bug with a more appropriate description
> (concerning the potential menu entry; see the comments above).
>
> But personally I think that an additional menu entry for a thing that is as
> rarely used (IMO) and as easily to do by other means

I might agree with you, if it did as you describe. Actually, I would rather have
the menu option, even if you could select the text and then do command-c (Mac) -
it is a much more possitive action to select a menu option.

> would be a waste of screen 
> estate and make it more difficult to find the desired menu entry (because the
> menu would get larger - and there are surely many other people who would like to  
> see various other entries in the context menu...)

Ah, I see this bug is marked 'Windows 2000'. Should I open another bug, or
should this bug be remarked as 'Mac' only? Ah, I see the latest 'add' says that
it doesn't work right on Linux either, so it doesn't make sense to mark it Mac
only, but it shouldn't be W2K if it works as described on that platform.

Anyway, please reopen this bug, since it clearly still needs some work.

Max.

PS. Remember, most Macs only have a single mouse button.

Comment 10

15 years ago
keith: you aren't dragging to copy, you're dragging an object because you want
to select the object because you want to copy the selection.

it does work on windows, although it doesn't work if there's already a selection...

ok, let's see if we have our definitions straight:
1. click a link
1' it should turn active (normally that's a red color)
(don't wait too long, esp on mac os, we aren't trying to trigger a context menu)
2. drag the mouse outside the active link's border
2' the text should select.
3. you somehow tell mozilla to copy (ctrl-c, cmd-c, edit>copy, context menu>copy)

please indicate which step you are unable to follow.
Status: RESOLVED → VERIFIED
Component: User Interface Design → XP Apps: GUI Features

Comment 11

15 years ago
All the methods you describe work for me, but they feel like hacks and really
horrible and non-intuitive.

Perhaps, when no text is selected, instead of greying-out the 'copy' item on the
menu, you could replace it with 'copy link text'?

I don't see any point in having a greyed out option. Replacing it with something
which is identical in functionality from the intent of the user, does not use
any further menu space.

Would this be satisfactory from all points of view?

Max.

Comment 12

15 years ago
thank you! yes, unintuitive is the word I think I was looking for. yes I would
be very happy with that.

Comment 13

15 years ago
Regarding comment 11:

There should not be a "Copy" item on the context menu that appears when you
right-click on a link (bug 187415), so please don't use its existence as a
reason to have a "Copy link text" item.

Comment 14

15 years ago
I am yet another person who often regrets the fact that the "Copy link title"
context menu option is missing, so count my vote. ;-)

Note that mailto: links already have "Copy Email Address" and "Copy Link
Location". Why not add "Copy Link Title"? Or, to make it absolutely clear what
the option does, it could be similar to the 'Web Search for "(selected
content)"' option that appears in a selection context menu.

OS/Platform=All. I'm tempted to reopen this...
OS: Windows 2000 → All
Hardware: PC → All

Comment 15

14 years ago
*** Bug 224085 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
I see this is marked WONTFIX but I hope I can still put in my two cents because
I want to respond to some of what's said here.

>> keithkml: what on earth is painful about clicking on a link and moving the
mouse slightly while holding the mouse button pressed to get the link text
selected? Afterwards just press Ctrl-C (on Win) or use the context menu to copy
the selected text.

Because unlike regular text, it's easy for me to miss. Too far away to the left
or right, and too much would be selected (spaces, line breaks, etc). Too close
and you hit the link instead. And then, when the text is selected, Ctrl-C means
going to the keyboard.

And then there's the problem of copying portions of link texts. Unlike regularly
phrases, it's impossible to do so. We're not even asking that, but just being
able to do it easier.

I also want to point out that, IMHO, omitting a normal copy function actually
creates exceptions. When you right-click on a link, it's selected. Thus, the
context menu should reflect that.

It should also be recognized that link texts are mostly regular words and text,
so it's a bit strange that they're not treated as text. Again, especially if
one's interested in portions thereof.

P.S. Sorry about filing the dupe - I didn't find it.
Product: Core → Mozilla Application Suite

Comment 17

12 years ago
*** Bug 245213 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design

Comment 18

8 years ago
I just tried the proposed method of copying the text (WinXP and Seamonkey 2.0.3), and it didn't work at all.

This is what I did:
0. no text selection present
1. Pushed down the left (primary) mouse button on a link
2. moved the mouse out of the link (the mouse cursor turns into the no-no sign)
3. released the mouse button

Nothing happened.  Maybe this works on *x only?  I know the current selection in PuTTY terminals is copied to the clipboard immediately, but this is not a common behaviour in other Windows programs.

When I release the mouse button in a textarea, the href text is inserted.

Sometimes a link is hard to select without activating it, so it would be nice if

- the mouse move method would reliably work, or
- a popup menu entry would be made available (to those who want it and throw
  the corresponding configuration lever, at least)
You need to log in before you can comment on or make changes to this bug.