Local files selected to be opened with "Open With..." are saved instead

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
10 months ago
10 months ago

People

(Reporter: Ross G, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

1.) Click a link on a web page for a video file (I have tried with wmv, avi, mp4, but I don't think this is specific to videos only)
2.) The "Open With/Save As" dialog box correctly appears, as I don't have the "Do this automatically..." checkbox checked for those file types
3.) I have the "Open With..." application as Windows Media Player as the default option, but I have tried other applications with the same result
4.) Click the "Ok" button to proceed


Actual results:

The file is downloaded


Expected results:

The file should have opened directly with the specified application.

I have tried with a brand new fresh profile and get the same result.
(Reporter)

Updated

10 months ago
Summary: Files selected to be opened with "Open With..." are saved instead → Local files selected to be opened with "Open With..." are saved instead
(Reporter)

Comment 1

10 months ago
I realized that in my original description I forgot to point out the important fact that this bug is related to local file links. I used to be able to open file:/// links directly with my chosen application as I guess Firefox would be smart enough to realize that it is a local link and can be opened directly from the file system without needing to download.

Comment 2

10 months ago
Please see the below steps and tell me if they are correct: 

 On a folder that is on my desktop (wmv, avi, mp4) -> click right and choose "Open with" -> choose Firefox

In my case the file is opened with Firefox. I need to have a downloaded link and then to choose to open with Firefox? 

I tested on win 7 x32 with FF 51 release.
Flags: needinfo?(root)
(Reporter)

Comment 3

10 months ago
No, the issue is with a web page that uses a local file:/// link to try to open a file locally. In this case the 'Open with...' option downloads the file anyway instead of passing the local link to the opener to open directly without downloading. This is how previous versions of FF worked (unfortunately I'm not sure exactly which version this changed, but it was a more recent version, 50+?).
Flags: needinfo?(root)

Comment 4

10 months ago
Do you have any add-ons on your profile? If yes please try to disable them and retest this issue to see if they are not affecting your profile. 
Please download Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.
Also a screen recorder with your scenario, if it's possible, can help a lot in this case. You can use: http://screencast-o-matic.com/home 
Thanks
Flags: needinfo?(root)
(Reporter)

Comment 5

10 months ago
And like magic the feature has been restored in 51.0.1. I tried Nightly as suggested and the feature was working there, so then I thought to re-check on my regular installation and it works again as-is, with no changes required from me. I was using the same profile, same add-ons, etc. So I'll mark this as resolved now. It's always nice when things just start working again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(root)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.