no color in context menu icons

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: vitalik.perevertun, Unassigned)

Tracking

({regression})

51 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8833544 [details]
context_menu.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

1. create userChrome.css in user profile with content
/* Firefox userChrome.css */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

#context-bookmarkpage image
{
    -moz-image-region: rect(48px, 16px, 64px, 0);
    list-style-image: url("Silk.png");
}
/* (or just install Menu Icons Plus addon) */

2. open new tab on any site(or empty)
3. open context menu (right click mouse)




Actual results:

"back", "next", "reload", "bookmark" buttons have no color(see screenshot after)

firefox 51


Expected results:

"back", "next", "reload", "bookmark" buttons must have color(see screenshot before)

firefox 50
(Reporter)

Comment 1

2 years ago
Created attachment 8833545 [details]
file Silk.png from addon Menu Icon Plus
Narrowed down the regression range to the following set of changes:
Last good revision: 417d1e27c8eaf63a737abd95cc26d912332f232f
First bad revision: a1727a7c7f2f5cb3d732c475567e421aed2f0ba8
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=417d1e27c8eaf63a737abd95cc26d912332f232f&tochange=a1727a7c7f2f5cb3d732c475567e421aed2f0ba8

Dao, would you please take a look?
Status: UNCONFIRMED → NEW
Component: Untriaged → Theme
Ever confirmed: true
Flags: needinfo?(dao+bmo)
Keywords: regression

Comment 3

2 years ago
[Tracking Requested - why for this release]:

browser:Firebox 51 

In my browser context menu icons are appearing with color.

It works properly in latest Version.
Created attachment 8834966 [details]
50 vs 51.jpg

I've used the default settings from the comment 0 addon, with no custom css for context, the issue reproduces in today's release build as well. (see attachment)
This isn't a Firefox bug, it needs to be fixed in your userChrome.css code or in the add-on, respectively.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dao+bmo)
Resolution: --- → INVALID
Try this:

#context-navigation > .menuitem-iconic > .menu-iconic-left > .menu-iconic-icon {
  filter: none;
}
(Reporter)

Comment 7

2 years ago
thanks It works.
You need to log in before you can comment on or make changes to this bug.