Firefox can't save two passwords for two paths on the same site if both use the same username

RESOLVED DUPLICATE of bug 263387

Status

()

Core
General
--
minor
RESOLVED DUPLICATE of bug 263387
a year ago
3 months ago

People

(Reporter: William, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

I have a website with a blog (Wordpress) and forum (phpbb). Both use the same username. When I save the password for one of them (eg the blog), Firefox overwrites the password allocated to the other (eg the forum). It seems that Firefox can't distinguish between the two apps because it only saves the path to the root directory, not the full path to the subdirectories containing the apps.


Actual results:

I log in to my admin panel for my blog (for example) for the first time and save the password. All is good and everything works fine. Then I log into my forum, which uses the same username, and save the password there for the first time. Oddly, Firefox asks to UPDATE the password rather than asking to SAVE it. Other than that, everything works fine.

But the next time I log in to the blog, the login fails. I check the saved passwords and find that only the password for the forum is listed. Apparently Firefox used the forum password. When I manually enter the correct password, Firefox asks to UPDATE it. After that the password list only contains the password for the blog.

This goes back and forth. Both apps are in the same root directory and both use the same username. But since Firefox doesn't list the full path to the different apps, it only distinguishes the two by username. Since the username is the same for both apps, Firefox only saves one password, overwriting the las one that got updated.


Expected results:

Firefox should either recognize the full path to the application directory or otherwise be able to distinguish between two applications that reside in the same website root directory and use the same username
(Reporter)

Updated

a year ago
Severity: normal → minor
(Reporter)

Comment 1

a year ago
Both apps are php and both are in the same level (website root directory). I'm using macOS Sierra and Firefox 51.0.1 (64-bit)
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263387
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.