Langpacks in archive.mozilla.org are served as "application/zip" instead of "application/x-xpinstall"

RESOLVED FIXED

Status

Release Engineering
Release Automation
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Carlos [nohamelin], Assigned: Sanchay, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=python][good first bug])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Same as bug 1290772.

Language packs in, for example:
https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central-l10n/linux-i686/xpi/

...are being served as "application/zip" instead of "application/x-xpinstall", so a direct install of langpacks from that page is not possible, and they need be download to disk and installed manually.
(Reporter)

Updated

a year ago
Blocks: 1290772
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [lang=python][good first bug]
In new beetmoverscript, we'd need to change this[1] from 'application/zip' to 'application/x-xpinstall'.

[1]: https://github.com/mozilla-releng/beetmoverscript/blob/master/beetmoverscript/constants.py#L13
I can help with this if someone wants to grab this. Otherwise, I can tweak it myself.
Mentor: mtabara
Component: General Automation → Release Automation
QA Contact: catlee → rail
(Assignee)

Comment 4

a year ago
Created attachment 8834123 [details] [diff] [review]
1336754.patch - Changed application/zip to application/x-xpinstall for direct install of langpacks in archive.mozilla.org

My first bug, hope I didn't mess it.
Attachment #8834123 - Flags: review?(mtabara)
Comment on attachment 8834123 [details] [diff] [review]
1336754.patch - Changed application/zip to application/x-xpinstall for direct install of langpacks in archive.mozilla.org

(In reply to Sanchay from comment #4)
> Created attachment 8834123 [details] [diff] [review]
> 1336754.patch - Changed application/zip to application/x-xpinstall for
> direct install of langpacks in archive.mozilla.org
> 
> My first bug, hope I didn't mess it.

Hi Sanchay! Thanks for stepping up for this.
Can I please ask you to open a PR against [1] for this fix, as opposed to patching it here?
That ensures your contribution stays in the repo history but also triggers automatic testing before merging.

[1]: https://github.com/mozilla-releng/beetmoverscript/
Attachment #8834123 - Flags: review?(mtabara) → review+
(Assignee)

Comment 6

a year ago
(In reply to Mihai Tabara [:mtabara]⌚️GMT from comment #5)
> Comment on attachment 8834123 [details] [diff] [review]
> 1336754.patch - Changed application/zip to application/x-xpinstall for
> direct install of langpacks in archive.mozilla.org
> 
> (In reply to Sanchay from comment #4)
> > Created attachment 8834123 [details] [diff] [review]
> > 1336754.patch - Changed application/zip to application/x-xpinstall for
> > direct install of langpacks in archive.mozilla.org
> > 
> > My first bug, hope I didn't mess it.
> 
> Hi Sanchay! Thanks for stepping up for this.
> Can I please ask you to open a PR against [1] for this fix, as opposed to
> patching it here?
> That ensures your contribution stays in the repo history but also triggers
> automatic testing before merging.
> 
> [1]: https://github.com/mozilla-releng/beetmoverscript/

Opened a PR request in the repo as suggested
(In reply to Sanchay from comment #6)
> (In reply to Mihai Tabara [:mtabara]⌚️GMT from comment #5)
> > Comment on attachment 8834123 [details] [diff] [review]
> > 1336754.patch - Changed application/zip to application/x-xpinstall for
> > direct install of langpacks in archive.mozilla.org
> > 
> > (In reply to Sanchay from comment #4)
> > > Created attachment 8834123 [details] [diff] [review]
> > > 1336754.patch - Changed application/zip to application/x-xpinstall for
> > > direct install of langpacks in archive.mozilla.org
> > > 
> > > My first bug, hope I didn't mess it.
> > 
> > Hi Sanchay! Thanks for stepping up for this.
> > Can I please ask you to open a PR against [1] for this fix, as opposed to
> > patching it here?
> > That ensures your contribution stays in the repo history but also triggers
> > automatic testing before merging.
> > 
> > [1]: https://github.com/mozilla-releng/beetmoverscript/
> 
> Opened a PR request in the repo as suggested

Merged it to the tree. We'll bump beetmoverscript to 0.2.2 at some point this week and land to production.
Thanks for your contribution!

I'll follow-up with a comment to confirm everything is good.
Assigning this to Sanchay since he's done the PR.
Will mark the bug as fixed as soon as we land the fix and have a confirmed mime type change.
Assignee: nobody → sanchay.pahalwani
The fix that Sanchay pushed in beetmoverscript is now landed with beetmoverscript 0.2.2

I've retriggered one of the beetmover jobs (specifically https://tools.taskcluster.net/task-group-inspector/#/DkilAL_fQcaDk9Ff0A-B-g/D9tjAYS3Tky9ACYXvuQAfg) and it looks like the corresponding http://archive.mozilla.org/pub/firefox/nightly/2017/02/2017-02-08-11-02-48-mozilla-central-l10n/linux-i686/xpi/firefox-54.0a1.ar.langpack.xpi is served now with "application/x-xpinstall" Content-type.

Due to S3 caching, might not just work from the first place but it's working correctly from the S3 beneath archive.m.o.
Good job Sanchay for your first contribution!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.