Closed Bug 1336768 Opened 3 years ago Closed 3 years ago

Tooltip in sidebar keep staying while mouse move

Categories

(Core :: DOM: Core & HTML, defect)

54 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla54
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 + verified

People

(Reporter: euthanasia_waltz, Assigned: bzbarsky)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
STR:
1. Start firefox, open bookmarks sidebar, expand tree if necessary
2. Move mouse pointer onto a bookmark and wait the tooltip is displayed
3. Move mouse pointer onto another bookmark

AR:
The tooltip keep staying, still appeared, not disappeared, until mouse pointer moved out the bookmarks tree area or moved on to the tooltip.

ER:
The tooltip disappears and a new tooltip for the bookmark under the mouse pointer appears.

mozregression:
 9:08.54 INFO: Last good revision: bf20544a7385ff761ba0da45fb4996153d88025f
 9:08.54 INFO: First bad revision: 12ae47283fc97ccfe5af32d6e6cca88e44ae901a
 9:08.54 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bf20544a7385ff761ba0da45fb4996153d88025f&tochange=12ae47283fc97ccfe5af32d6e6cca88e44ae901a
 9:09.65 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1332812
Blocks: 835981
Flags: needinfo?(bzbarsky)
Keywords: regression
This change in nsXULTooltipListener::GetSourceTreeBoxObject is clearly wrong:

-    nsCOMPtr<nsIDOMXULElement> xulEl(do_QueryInterface(sourceNode->GetParent()));
+    RefPtr<nsXULElement> xulEl = nsXULElement::FromContent(sourceNode);

and fixing that makes the problem go away.
Assignee: nobody → bzbarsky
Flags: needinfo?(bzbarsky)
Comment on attachment 8834035 [details] [diff] [review]
Use the right element to get our tree box object from; fixes problem introduced in <https://hg.mozilla.org/integration/mozilla-inbound/rev/d4cafa51586a>

oops
Attachment #8834035 - Flags: review?(bugs) → review+
Tracking 54+ for this regression.
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/558a9f23b39c
Use the right element to get our tree box object from; fixes problem introduced in <https://hg.mozilla.org/integration/mozilla-inbound/rev/d4cafa51586a>.  r=smaug
atlanto, thank you for the awesome bug report!

Loic, thank you for the needinfo!
https://hg.mozilla.org/mozilla-central/rev/558a9f23b39c
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
I have reproduced this issue using Firefox 54.0a1 (2017.02.04, build ID=20170204030205) on Win 10 x64.
I can confirm this issue is fixed, I verified using Firefox 54.0b1 on Win 8.1 x64, Mac OS X 10.10 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.