Black flickering when playing Fullscreen video on new MacBook Pro Touchbar

RESOLVED DUPLICATE of bug 1333952

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1333952
2 years ago
2 years ago

People

(Reporter: l1458494, Unassigned)

Tracking

51 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

When watching videos in Fullscreen there is flickering. Every few seconds seemingly randomly a black retangle covers a big portion of the screen for a brief moment and then goes away. This makes videos not unwatchable but it's very annoying.
(Reporter)

Comment 1

2 years ago
EDIT: The problem occurs not only on YouTube but also on other sites when playing Fullscreen video.
(Reporter)

Updated

2 years ago
Summary: YouTube black flickering in Fullscreen on new MacBook Pro Touchbar → Black flickering when playing Fullscreen video on new MacBook Pro Touchbar

Updated

2 years ago
Component: Untriaged → Graphics
OS: Unspecified → Mac OS X
Product: Firefox → Core
l1458494: Could you please copy the "graphics" section from about:support?
Flags: needinfo?(l1458494)
Priority: -- → P3
(Reporter)

Comment 3

2 years ago
(In reply to Andrew Osmond [:aosmond] from comment #2)
> l1458494: Could you please copy the "graphics" section from about:support?

Allgemeine Merkmale
Compositing	OpenGL
Asynchrones Wischen und Zoomen	nichts
WebGL-Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
WebGL2-Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
H264-Dekodierung durch Hardware	Yes
Audio-Back-End	audiounit
GPU 1
Aktiv	Ja
Herstellerkennung	0x8086
Gerätekennung	0x1927
Weitere Informationen
AzureCanvasAccelerated	1
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	none
TileHeight	1024
TileWidth	1024
(Reporter)

Comment 4

2 years ago
Here is a video showing the bug in action by playing a random video from Youtube. Surprisingly when I was trying to screengrab the video the bug didn't show up anymore so I had to use my phone to record it. You can clearly see the black bar on the lower half of the screen randomly appearing for a brief moment. Don't know if it helps any further but it should at least confirm this bug.

https://workupload.com/file/VrZV68K
Flags: needinfo?(l1458494)

Comment 5

2 years ago
I hope this comment gives more information. This bug happened to me on Netflix as well, and caused more distortion than the video showed in the reporter's video. This level of distortion is less frequent, but still reoccurring. With this level of distortion viewing the video is essentially unwatchable. I hope some of this information is useful, this is my first time reporting a bug on here. Note* the sound was muted for language

http://workupload.com/file/M3nCnJ8

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0

Build Number: 20170125094131

Graphics:

Compositing	OpenGL
Asynchronous Pan/Zoom	wheel input enabled
WebGL Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
WebGL2 Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
Hardware H264 Decoding	Yes
Audio Backend	audiounit
GPU #1
Active	Yes
Vendor ID	0x8086
Device ID	0x1927
Diagnostics
AzureCanvasAccelerated	1
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	none
TileHeight	1024
TileWidth	1024

Comment 6

2 years ago
Hey there,

I have this bug too. I tried 3 versions of Firefox (FF 52, FF Nightly 54 and FF Nightly 55)

It appears while watching Youtube- and Vimeo-Videos. But I also see it for example in the Outlook Web App when there is a popup alert. (everything with fullscreen)

Maybe it's coincidence, but the language of my MacBook Pro is German, the same as "l1458494".

Here are my bug-fix-information:

Compositing	OpenGL
Asynchrones Wischen und Zoomen	Mausrad-Eingabe aktiviert; Ziehen der Bildlaufleiste aktiviert
WebGL 1 Driver WSI Info	CGL
WebGL 1 Driver Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
WebGL 1 Driver Version	2.1 INTEL-10.22.29

WebGL 2 Driver WSI Info	CGL
WebGL2-Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
WebGL 2 Driver Version	4.1 INTEL-10.22.29
Audio-Back-End	audiounit
GPU 1
Aktiv	Ja
Herstellerkennung	0x8086
Gerätekennung	0x1927
Weitere Informationen
AzureCanvasAccelerated	1
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	none
TileHeight	1024
TileWidth	1024
failures	CP+[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.
Entscheidungsprotokoll
WEBRENDER	
unavailable by runtime: Build doesn't include WebRender
Fehlerprotokoll
(#0) 	CP+[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.
(#48 ... #62) 	CP+[GFX1-]: ClientLayerManager::BeginTransaction with IPC channel down. GPU process may have died.

Comment 7

2 years ago
This happens to me every day on Firefox, even with no videos on tabs.

Exiting Full Screen fixes it (until it happens again 12 hours later).

Still present on 52.0.

Comment 8

2 years ago
I notice that in Firefox, the tab bar paints off screen to the left. 

Example: https://www.dropbox.com/s/s9tkqkk8gkuce9f/Offscreen%20Firefox%2C%20causes%20flickering.png?dl=0

Using the app causes it to repaint the screen, bringing the left tab back onscreen, but it starts flickering soon after.

Comment 9

2 years ago
Also experiencing this issue since day 1 on my 2016 13" with Iris 550. Would also like to confirm that it's not only during video. I for instance am currently working in the backend of a WordPress site and the screen is flickering like crazy in full screen mode. When I close the lid or resize the window it stops although I have had a few instances where the flicker took over the whole machine and I had to restart.

I disabled hardware rendering as suggested in other forums, but it had zero effect.

I'm also running 52.0.


about:support 

Features
Compositing	Basic
Asynchronous Pan/Zoom	wheel input enabled
WebGL Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
WebGL2 Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
Hardware H264 Decoding	Yes
Audio Backend	audiounit
GPU #1
Active	Yes
Vendor ID	0x8086
Device ID	0x1927
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	none
TileHeight	1024
TileWidth	1024
failures	CP+[GFX1-]: Failed to allocate a surface due to invalid size (CDT) Size(0,0)
Decision Log
HW_COMPOSITING	
disabled by user: Disabled by pref
OPENGL_COMPOSITING	
unavailable by default: Hardware compositing is disabled
Failure Log
(#0) 	CP+[GFX1-]: Failed to allocate a surface due to invalid size (CDT) Size(0,0)
(#5) Error	Failed to create a valid ShmemTextureHost
(#6) Error	Failed to create a valid ShmemTextureHost
(#7) Error	Failed to create a valid ShmemTextureHost
(#8) Error	Failed to create a valid ShmemTextureHost
(#9) Error	Failed to create a valid ShmemTextureHost
(#10) Error	Failed to create a valid ShmemTextureHost
(#11) Error	Failed to create a valid ShmemTextureHost
(#12) Error	Failed to create a valid ShmemTextureHost
(#13) Error	Failed to create a valid ShmemTextureHost
(#14) Error	Failed to create a valid ShmemTextureHost
(#15) Error	Failed to create a valid ShmemTextureHost
(#16) Error	Failed to create a valid ShmemTextureHost
(#17) Error	Failed to create a valid ShmemTextureHost
(#18) Error	Failed to create a valid ShmemTextureHost
(#19) Error	Failed to create a valid ShmemTextureHost

Comment 10

2 years ago
He,

same on my 13" non Touchbar Macbook Pro 2016.
Using FF 52
Mac OS Sierra 10.12.3

Have the same issue - at every situation using FF (not only watching videos at youtube). Flickers massivley occur at least 2-3 times within 30minutes. (Had several flickers during the time I wrote this...)

Its defintely not a hardware issue:
# I cleared the system management controller (SMC)
# installed OS fresh from recovery
# drove the system in Save mode 
# resetted NVRAM


With Safari or Chrome no flickers / problems occuring.


Would be great to have a solution on this - at the moment I have to use chrome instead of FF :/

Comment 11

2 years ago
I noticed that this problem only occurs on 13" Macbook Pro. The aspect ratio of the screen could be a cause of the problem.

As i know for sure Macbook Air uses in some cases an aspect ratio of 4:3, I cant really find any specifications to which aspect ratios the Macbook Pro 13" uses for the different resolutions

I myself have this same problem and have also narrowed it down to only be a problem occuring while usig Firefox. Also only on my Macbook Pro 13", not on my Macbook Pro 15" (2013) or Mac Mini (2014)

Comment 12

2 years ago
Happens on my tMBP 15" (2016).

Comment 13

2 years ago
Hi,

I'm having this issue on my 13" Macbook Pro 2016 with Touchbar.
It happens randomly when using Firefox in fullscreen view.
Apparently if there are more applications in fullscreen it gets worse.

MacOs Sierra 10.12.3
FF 52.0.1

Comment 14

2 years ago
Hello,

FF 52.0.1
MacBook Pro 13' Touchbar 2016
Intel Iris Graphics 550

Experiences same issues described on posts above. Lower end of the screen flickers when watching full screen videos on FF. Continues to flicker out of full screen mode while the video plays.

Tested disabling hardware acceleration, no change.

Safari & Chrome, no issues.

My friend with the non touchbar MacBook 2016 has the exact same issue on FF 52.0.1.

Comment 15

2 years ago
Hi,

Same issue on my 13" Macbook Pro 2016 with Touchbar.
Happens randomly when using Firefox in fullscreen view, even without video
Stops when I exit full screen

MacOs Sierra 10.12.3
FF 52.0.1

Graphics
Features
Compositing	OpenGL
Asynchronous Pan/Zoom	none
WebGL Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
WebGL2 Renderer	Intel Inc. -- Intel(R) Iris(TM) Graphics 550
Hardware H264 Decoding	Yes
Audio Backend	audiounit
GPU #1
Active	Yes
Vendor ID	0x8086
Device ID	0x1927
Diagnostics
AzureCanvasAccelerated	1
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	none
TileHeight	1024
TileWidth	1024

Comment 16

2 years ago
The issue appears to be fixed for me on Sierra 10.12.4 and FF 52.0.1.
(In reply to clemenko from comment #16)
> The issue appears to be fixed for me on Sierra 10.12.4 and FF 52.0.1.

We have heard this from other sources as well - 10.12.4 fixes issues with the new 13".  Any of the other reporters that have had a chance to update still see the problem?
Whiteboard: [gfx-noted]

Comment 18

2 years ago
10.12.4 has fixed it for me as well thank you!

Comment 19

2 years ago
Yep, 10.12.4 seems to have sorted this issue for me too.
Great!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333952
Thanks everyone who confirmed. This is great news!
You need to log in before you can comment on or make changes to this bug.