Using the mouse wheel moves calendar multiple months ahead or back

RESOLVED DUPLICATE of bug 1139302

Status

RESOLVED DUPLICATE of bug 1139302
2 years ago
2 years ago

People

(Reporter: shawnmsrm, Unassigned)

Tracking

Lightning 5.4

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

I was going back and forth between the multiweek and month view looking at items I created. I was using the left and right arrows next to the "Today" option (jumps to today). The arrows were working OK moving between months. I then tried using the scroll wheel on my mouse to move between months / multiweeks instead of using the arrow keys to the left and right of the "Today" option.


Actual results:

When I used the scroll wheel to try and move one month ahead / back and only moved the wheel very slightly forward / backwards, the months in view jumped to maybe 12 months ahead, fours months ahead (or back based on direction of scroll wheel). The number of months moved did vary.

Using the wheel in the day or week view worked OK.

I then tried using the wheel in other programs  / webpages and the amount of movement based on the scrolling I did with the wheel worked OK.




Expected results:

I expected the month displayed (either using the multiweek or month view) to increase or decrease the same as using the left or right arrows keys next to the "Today" option - basically on month at a time. I understand if I scrolled much, the months shown would be earlier / later and more than one month, but it doesn't look to be one month at a time.

I am using Windows 10 and a Logitech wireless mouse M557.

I did find this bug (Bug 241040) about the wheel, but it was reported in 2004 and last updated on 2007.

Comment 1

2 years ago
If your mouse has a setting "smooth scrolling" enabled, it might be a duplicate of bug 1139302.
Please, try to read there, or in the duplicate bug 1250278, to see if the issue is the same.
(Reporter)

Comment 2

2 years ago
Yes, I had smooth scrolling turned on. When I turned it off, the scrolling didn't work that well in Thunderbird and other programs. I think my issue is a combination of both previous noted bugs, so yes my bug is a duplicate.

Comment 3

2 years ago
Thanks, marking as duplicate then.
I attached in that bug a wip patch for the month view. Would be great if you could try it because I suspect that a right behavior with the option "smooth scrolling" enabled depends also on the kind of mouse.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139302
You need to log in before you can comment on or make changes to this bug.