Closed Bug 1336922 Opened 3 years ago Closed 3 years ago

Disable v4 update in test_safe_browsing_initial_download.py testcase

Categories

(Toolkit :: Safe Browsing, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: dimi, Assigned: francois)

References

Details

Attachments

(1 file)

Google reports us there is about 4000 update requests with no_google_api_key.
It is very likely because of try debug build(Window/Linux) running test_safe_browsing_initial_download.py testcase.

So we should disable this test for v4 update at least for one week and see if google would still receive requests with no_google_api_key. If no, then we can confirm that's the root cause.
Assignee: nobody → francois
Status: NEW → ASSIGNED
Priority: -- → P1
Blocks: 1336915
Henrik, I know you probably don't know what this code does, but I couldn't really think of a good reviewer for this change.

I'm hardcoding the values of these prefs to ensure that we don't download the new V4 lists.

We intend to have this patch for a week or two to try and see if these tests were the root cause of the errors that Google are seeing. It will be backed out by bug 1336915 (the real fix for these errors).
Comment on attachment 8834308 [details]
Bug 1336922 - Temporarily disable V4 updates in test_safe_browsing_initial_download.py.

https://reviewboard.mozilla.org/r/110292/#review111448

When it helps diagnosing issues with downloading the tables, lets go ahead and land it!
Attachment #8834308 - Flags: review?(hskupin) → review+
Pushed by fmarier@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2820983e1e6
Temporarily disable V4 updates in test_safe_browsing_initial_download.py. r=whimboo
sorry had to back this out for test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=75167234&repo=autoland
Flags: needinfo?(francois)
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e6e01878350e
Backed out changeset a2820983e1e6 for flake8 failure
Flags: needinfo?(francois)
Pushed by fmarier@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/734ac707469b
Temporarily disable V4 updates in test_safe_browsing_initial_download.py. r=whimboo
https://hg.mozilla.org/mozilla-central/rev/734ac707469b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.