Closed Bug 1337009 Opened 3 years ago Closed 3 years ago

Re-enable CSS shapes reftests and CSS text reftests on Windows debug builds

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: jeremychen, Assigned: vliu)

Details

Attachments

(1 file)

Per bug 1300355 comment 32, I think it might be a good time to re-enable these tests.
Hi Vincent, you already have a ready-for-review patch, right? I know that bug 1300355 comment 32 is what you concern about. However, since we only disable these tests on debug builds, the intermittent on opt builds is probably not related. IMHO, we should re-enable these tests as long as the intermittent on debug builds are gone.

Ting-Yu, any thoughts?
Flags: needinfo?(vliu)
Flags: needinfo?(tlin)
From the past information I'd looked into, this issue on Bug 1300355 might be a OOM case. The place where crash happens is inconsistent and is not for any specific one. The link in bug 1300355 comment 32 probably indicate that environment variable change in machine so that the result all greens after many trials. If so, maybe we can treat debug/opt build as different case to track. I will enable them in this bug. Here to post the link moving from bug 1300355 comment 32.


[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d28066d93e0370b4b46fe8c3ee9e49812da58a0f
Flags: needinfo?(vliu)
Assignee: nobody → vliu
Hi TYLin, jeremychen,

Can you please have a review? Thanks
Attachment #8834223 - Flags: review?(tlin)
Attachment #8834223 - Flags: review?(jeremychen)
Attachment #8834223 - Flags: review?(tlin) → review+
Re comment 1:

I agree that re-enable the tests on windows debug builds doesn't seem to increase the failure rate on opt builds, so let's re-enable them.
Flags: needinfo?(tlin)
Comment on attachment 8834223 [details] [diff] [review]
0001-Bug-1337009-Re-enable-CSS-shapes-reftests-and-CSS-te.patch

Review of attachment 8834223 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you for following this up. Please do another round of try run. r=me if try result with the latest tree status is positive.
Attachment #8834223 - Flags: review?(jeremychen) → review+
(In reply to Jeremy Chen [:jeremychen] UTC+8 from comment #5)
> Comment on attachment 8834223 [details] [diff] [review]
> 0001-Bug-1337009-Re-enable-CSS-shapes-reftests-and-CSS-te.patch
> 
> Review of attachment 8834223 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Thank you for following this up. Please do another round of try run. r=me if
> try result with the latest tree status is positive.

try result: https://treeherder.mozilla.org/#/jobs?repo=try&revision=10163f5635bc1de566ac46d01ef231e46e2d6b35

It seems that we still got crash on Win7 debug build. The system still contains failure rate on opt/debug build. Based on this, I would like to wait landing it until the issue is more clear.
Since the status of Bug 1300355 goes more clear, I would like to land this part to enable those reftests.

Try result: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8631f4505ad5bc090d1f8e63be9e08c35a08f9e0&selectedJob=81029075
Pushed by vliu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/be73ab1cdcd6
Re-enable CSS shapes reftests and CSS text reftests on Windows debug builds. r=TYLin, jeremychen
https://hg.mozilla.org/mozilla-central/rev/be73ab1cdcd6
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.