Switch nsLocaleService to use OSPreferences

RESOLVED DUPLICATE of bug 1356263

Status

()

Core
Internationalization
P3
normal
RESOLVED DUPLICATE of bug 1356263
10 months ago
4 months ago

People

(Reporter: gandalf, Assigned: gandalf)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

10 months ago
Once bug 1333184 lands, we can remove the os-specific code from nsLocaleService and use OSPreferences instead.
(Assignee)

Updated

10 months ago
Depends on: 1333184
(Assignee)

Updated

10 months ago
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
(Assignee)

Comment 1

10 months ago
So, it's a bit more tricky, because currently nsLocaleService exposes systemLocale and applicationLocale and for UNIX it also deal with the categories.

I think I'll start by migrating callsites to this API to use the new API instead of migrating this code.

Updated

9 months ago
Priority: -- → P3
(Assignee)

Comment 2

4 months ago
In bug 1356263 we'll remove nsLocaleService overall.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1356263
You need to log in before you can comment on or make changes to this bug.