Unable to open Indexeddb connection while privacy > history is set to "Never remember"

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: sonicolas, Unassigned)

Tracking

(Depends on 1 bug)

53 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

725 bytes, application/x-zip-compressed
Details
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

1. Make sure that History setting is set to "Never Remember"
2. Attempt to open an IndexedDB connection in a WebExtension addon (Load temporary addon)


Actual results:

A DOMError was triggered with message "A mutation operation was attempted on a database that did not allow mutations."


Expected results:

No error should have occurred
Ah, this seems to happen on any sites. The code snippet included in the zip would reproduce the problem on example.com if pasted in the console.

Adjusting title.
Summary: Unable to open Indexeddb connection in webextension while privacy > history is set to "Never remember" → Unable to open Indexeddb connection while privacy > history is set to "Never remember"
Component: Untriaged → DOM: IndexedDB
Product: Firefox → Core
Is this related to IDB not being supported in PB? It sort of feels like it's working as intended ...
Flags: needinfo?(kyle)
AFAIK, "Never remember history" is basically private browsing outside of a few specific instances not having to do with IDB. Along with that, the "A mutation operation..." error message is used when NS_ERROR_DOM_INDEXEDDB_NOT_ALLOWED_ERR is thrown, which is the error we use for private browsing IDB currently. So this is working as intended until we get IDB in PB working.
Flags: needinfo?(kyle)
I'm going to close this but if there's something we're missing, please re-open. Thank you.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Marking as depending on the IDB in PB bug, just to remind myself to write a test for this case once we get PB IDB done.
Depends on: 781982
You need to log in before you can comment on or make changes to this bug.