Closed Bug 1337108 Opened 3 years ago Closed 3 years ago

Crash in nsDocShell::EndPageLoad operating in newsgroup

Categories

(Thunderbird :: General, defect, critical)

54 Branch
Unspecified
All
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1336802

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: crash, regression, regressionwindow-wanted)

Crash Data

I've crashed twice today clicking in newsgroup with 20170204030204 54.0a1. There are few others for 54.0a1 today [1] - so it would seem there is a regression on trunk

bp-10acd56f-a301-4029-806c-1a1302170206 selected a few articles to mark them as read (I don't know if it crashed before or after I hit "r")

bp-9eea3053-2704-43aa-8368-777872170206 clicked message header widget in message preview to collapse the full header.

0 	xul.dll	nsDocShell::EndPageLoad(nsIWebProgress*, nsIChannel*, nsresult)	docshell/base/nsDocShell.cpp:7944
1 	xul.dll	nsDocShell::OnStateChange(nsIWebProgress*, nsIRequest*, unsigned int, nsresult)	docshell/base/nsDocShell.cpp:7430
2 	xul.dll	nsDocLoader::DoFireOnStateChange(nsIWebProgress* const, nsIRequest* const, int&, nsresult)	uriloader/base/nsDocLoader.cpp:1256
3 	xul.dll	nsDocLoader::doStopDocumentLoad(nsIRequest*, nsresult)	uriloader/base/nsDocLoader.cpp:841
4 	xul.dll	nsDocLoader::DocLoaderIsEmpty(bool)	uriloader/base/nsDocLoader.cpp:731
5 	xul.dll	nsDocLoader::DocLoaderIsEmpty(bool)	uriloader/base/nsDocLoader.cpp:734
6 	xul.dll	nsDocLoader::OnStopRequest(nsIRequest*, nsISupports*, nsresult)	uriloader/base/nsDocLoader.cpp:613
7 	xul.dll	mozilla::net::nsLoadGroup::RemoveRequest(nsIRequest*, nsISupports*, nsresult)	netwerk/base/nsLoadGroup.cpp:633
8 	xul.dll	nsDocument::DoUnblockOnload()	dom/base/nsDocument.cpp:8816
9 	xul.dll	nsDocument::UnblockOnload(bool)	dom/base/nsDocument.cpp:8742
10 	xul.dll	nsBindingManager::DoProcessAttachedQueue()	dom/xbl/nsBindingManager.cpp:404
11 	xul.dll	mozilla::detail::RunnableMethodImpl<mozilla::gmp::GMPProcessParent* const, void ( mozilla::gmp::GMPProcessParent::*)(void), 0, 0>::Run()	C:/builds/moz2_slave/tb-c-cen-w64-ntly-000000000000/build/objdir-tb/dist/include/nsThreadUtils.h:867 

[1]
bp-bf197b04-19ef-4398-a0bc-31e062170206 	2017-02-06 06:09:04 	Thunderbird 	54.0a1 	20170204030204 	Linux
bp-c3ff3bc4-b407-4c1c-b166-3599b2170206 	2017-02-06 05:57:02 	Thunderbird 	54.0a1 	20170204030204 	Linux
bp-4e1fb093-7499-495e-9605-a23532170206 	2017-02-06 05:56:25 	Thunderbird 	54.0a1 	20170204030204 	Linux
bp-01ffc1bb-dd33-435f-829e-b19c92170204 	2017-02-04 19:38:25 	Thunderbird 	54.0a1 	20170204030204 	Linux
bp-06a718e9-9a77-4cf3-bdc7-5cf082170205 	2017-02-05 17:44:16 	Thunderbird 	54.0a1 	20170205030204 	Windows NT
Depends on: 1336802
Crash gone from dailies after bug 1336802  fixed
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1336802
You need to log in before you can comment on or make changes to this bug.