don't use RemoveElementAt(0) in APZ's Axis class

RESOLVED FIXED in Firefox 54

Status

()

Core
Graphics
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: froydnj, Assigned: froydnj)

Tracking

unspecified
mozilla54
Points:
---

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 months ago
We can more simply perform any processing we need, and then use Clear to
clear the array in one go.
(Assignee)

Comment 1

9 months ago
Created attachment 8834154 [details] [diff] [review]
don't use RemoveElementAt(0) in APZ's Axis class

I'm pretty sure the second hunk is obviously correct, but it's not clear to me
whether new entries could possibly be added to the array in the first hunk
(which would be ugly, but...).
Attachment #8834154 - Flags: review?(botond)
Comment on attachment 8834154 [details] [diff] [review]
don't use RemoveElementAt(0) in APZ's Axis class

Review of attachment 8834154 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8834154 - Flags: review?(botond) → review+

Comment 3

9 months ago
Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7f8b87c0e88c
don't use RemoveElementAt(0) in APZ's Axis class; r=botond

Comment 4

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7f8b87c0e88c
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.