Provide a mechanism for reading preferences set by a distribution

RESOLVED DUPLICATE of bug 1230802

Status

RESOLVED DUPLICATE of bug 1230802
2 years ago
7 months ago

People

(Reporter: mkaply, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
For WebExtensions in a distribution, we need the ability to set preferences that are then read by the WebExtensions so they can know if they are part of a distribution.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1230802
I'm de-duping this.  The use cases are different and I don't think they should be conflated into storage.managed.  A distribution may depend on distribution specific settings in its addons, such as partner codes, etc.

We could provide storage.distribution as a firefox specific api.  storage.json can live in the distributions directory, and storage.distribution would be read-only.
Blocks: 1215059
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This may depend on bug 1230802
Depends on: 1230802
They're not. storage.managed provides mechanisms to specify managed settings at a few different levels, including group policy, profile, and distribution. They all wind up in the same storage.managed bucket.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1230802

Updated

7 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.