Closed Bug 1337260 Opened 5 years ago Closed 5 years ago

Add telemetry probe to compare the V2 and V4 download protection lists

Categories

(Toolkit :: Safe Browsing, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1331139

People

(Reporter: francois, Assigned: tnguyen)

References

Details

Similarly to the probes added in bug 1311931 and bug 1298257, we want to validate that the V4 download protection lists are working as well as the V2 ones.

Specifically, we want to track:

1. whether prefixes looked up in the two download protection lists are: not found, V2 only, V4 only, both V2 and V4 (just like URLCLASSIFIER_PREFIX_MATCH)

2. whether full hashes are: not found, V2 only, V4 only or both V2 and V4

I suggest URLCLASSIFIER_DOWNLOAD_PREFIX_MATCH and URLCLASSIFIER_DOWNLOAD_FULL_MATCH for these two probes.
I would like to use URLCLASSIFIER_DOWNLOAD_MATCH_RESULT to merge both prefix and completion match telemetry.
That will have better coverage to compare download protection v2 vs v4
Let's do this as part of the download protection V4 patch.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1331139
You need to log in before you can comment on or make changes to this bug.