URL not properly updated on Reddit when navigating to the next page

RESOLVED FIXED in Firefox 52

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: arv, Assigned: JanH)

Tracking

51 Branch
Firefox 54
All
Android
Points:
---

Firefox Tracking Flags

(fennec52+, firefox51 wontfix, firefox52 fixed, firefox-esr52 fixed, firefox53 verified, firefox54 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
str
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160606113944

Steps to reproduce:

1. Navigate to https://m.reddit.com/
2. Scroll to bottom; tap "NEXT" button at bottom right to navigate to the next page of content
3. Tap location bar to notice the URL has updated to reflect the new page (eg, https://www.reddit.com/?count=25&page=1&after=t3_5sf6ns)
4. Kill Firefox from Android task manager
5. Restart Firefox 


Actual results:

* After navigating to the second page, the location bar display is not updated properly, showing only https://www.reddit.com/ until I tap it, when it displays the actual URL of the current page
* After Firefox is restarted, the front page that I navigated away from is restored


Expected results:

* The location should have updated to display the correct URL without having to tap to select the location
* The page I was on when Firefox was killed should have been restored

I suspect the problem is related to a javascript page transition on the Reddit site, but I have not investigated this, so I could be wrong.
(Assignee)

Comment 1

2 years ago
(In reply to arv from comment #0)
> * The page I was on when Firefox was killed should have been restored

The history change listener we have on each tab object (https://dxr.mozilla.org/mozilla-central/rev/af8a2573d0f1e9cc6f2ba0ab67d7a702a197f177/mobile/android/chrome/content/browser.js#4511) needs to be hooked up to the session store so as to match desktop behaviour (compare https://dxr.mozilla.org/mozilla-central/rev/af8a2573d0f1e9cc6f2ba0ab67d7a702a197f177/browser/components/sessionstore/content/content-sessionStore.js#323). At the moment we're only listening for DOMTitleChanged, which doesn't trigger here.

> * After navigating to the second page, the location bar display is not
> updated properly, showing only https://www.reddit.com/ until I tap it, when
> it displays the actual URL of the current page

This probably has a similar cause, but needs some further investigation as to which bit actually needs fixing.
Assignee: nobody → jh+bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hello,

Since this issue is related to the URL displaying, I'm moving this report to Awesomescreen component. Please move it to the correct component if I'm wrong. Thank you.
Component: General → Awesomescreen
(Reporter)

Comment 3

2 years ago
Only part of the issue is related to the URL displaying -- the incorrect URL is also being stored as part of the session, and restores to a different page than was being displayed on shutdown.  Should I file the session behaviour as a separate bug?
(Assignee)

Updated

2 years ago
See Also: → bug 1337940
(Assignee)

Updated

2 years ago
OS: Unspecified → Android
Hardware: Unspecified → All
Summary: URL not properly updated or restored on Reddit when navigating to the next page → URL not properly updated on Reddit when navigating to the next page
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
tracking-fennec: --- → ?
status-firefox51: --- → fix-optional
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox54: --- → affected

Comment 5

2 years ago
mozreview-review
Comment on attachment 8836374 [details]
Bug 1337264 - Don't depend on page title changes for updating the displayed URL.

https://reviewboard.mozilla.org/r/111798/#review113268

LGTM. Thanks!
Attachment #8836374 - Flags: review?(s.kaspari) → review+

Comment 6

2 years ago
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/94a2ac4a5806
Don't depend on page title changes for updating the displayed URL. r=sebastian

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/94a2ac4a5806
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Do you think it's worth uplifting this?
Flags: needinfo?(jh+bugzilla)
(Assignee)

Comment 9

2 years ago
Comment on attachment 8836374 [details]
Bug 1337264 - Don't depend on page title changes for updating the displayed URL.

Approval Request Comment
[Feature/Bug causing the regression]: Awesomebar
[User impact if declined]: Displayed URL may not update when a pages uses pushState() for its navigation and doesn't change the page title.
[Is this code covered by automated tests?]: Probably not.
[Has the fix been verified in Nightly?]: Yes.
[Needs manual test from QE? If yes, steps to reproduce]:  No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: This just makes sure that a pure top level location change (without a title change or a full page load) updates the displayed URL as well.
[String changes made/needed]: none
Flags: needinfo?(jh+bugzilla)
Attachment #8836374 - Flags: approval-mozilla-beta?
Attachment #8836374 - Flags: approval-mozilla-aurora?
Hi Brindusa, 
Could you help find someone to verify if this issue was fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(brindusa.tot)
tracking-fennec: ? → 52+
Carmen, could you please verify this bug on latest Nightly?
Flags: needinfo?(brindusa.tot)
QA Contact: carmen.fat
Hello, 

Tested on latest Nightly build 54.0a1 (2017-02-15) using the following devices:
- Oneplus Two (Android 6.0.1);
- Samsung Galaxy Note 4 (Android 5.0.1);
- Huawei MediaPad M2 (Android 5.1.1).

Following the STR from the Description results into displaying the updated URL when going to the next page of the website.
I'm marking this as Verified for Firefox 54.
status-firefox54: fixed → verified
Comment on attachment 8836374 [details]
Bug 1337264 - Don't depend on page title changes for updating the displayed URL.

Fix an awesomebar issue on Reddit and was verified on nightly. Aurora53+.
Attachment #8836374 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Jan Henning [:JanH] from comment #9)
> [Is this code covered by automated tests?]: Probably not.

Is there any chance this could be addressed? :)

Comment 15

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/7f305a9951d3
status-firefox53: affected → fixed
Tested on latest Aurora build 53.0a2 (2017-02-17) using the following devices:
- HTC Desire 820  (Android 6.0.1);
- Samsung Galaxy Note 4 (Android 5.0.1);
- Asus ZenPad 8 (Android 6.0.1).

Following the STR from the Description results into displaying the updated URL when going to the next page of the website.
I'm marking this as Verified for Firefox 53.
status-firefox53: fixed → verified
Comment on attachment 8836374 [details]
Bug 1337264 - Don't depend on page title changes for updating the displayed URL.

update url displayed by fennec even if page title is unchanged; beta52+
Attachment #8836374 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
status-firefox51: fix-optional → wontfix

Comment 18

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/ddf62df9e2e2
status-firefox52: affected → fixed

Comment 19

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr52/rev/ddf62df9e2e2
status-firefox-esr52: --- → fixed
You need to log in before you can comment on or make changes to this bug.