Closed Bug 1337276 Opened 3 years ago Closed 3 years ago

NextFrameSeekingState might still have a pending audio request when seeking to the end

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: jwwang, Assigned: jwwang)

References

Details

Attachments

(1 file)

http://searchfox.org/mozilla-central/rev/f5077ad52f8b90183e73038869f6140f0afbf427/dom/media/MediaDecoderStateMachine.cpp#2276

There might be still a pending audio request when seeking to the end of media. We should discard the request so we won't add audio samples to a finished queue and break the invariants of the COMPLETED state.
https://treeherder.mozilla.org/logviewer.html#?job_id=74842273&repo=try&lineNumber=8272

This bug is discovered by jya.
Assignee: nobody → jwwang
Priority: -- → P3
Attachment #8834277 - Flags: review?(kaku)
Comment on attachment 8834277 [details]
Bug 1337276 - discard the audio request so we won't add audio samples to a finished queue.

https://reviewboard.mozilla.org/r/110270/#review111446
Attachment #8834277 - Flags: review?(kaku) → review+
Thanks!
Pushed by jwwang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/300f05ba7536
discard the audio request so we won't add audio samples to a finished queue. r=kaku
https://hg.mozilla.org/mozilla-central/rev/300f05ba7536
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
See Also: → 1338697
Comment on attachment 8834277 [details]
Bug 1337276 - discard the audio request so we won't add audio samples to a finished queue.

Approval Request Comment
[Feature/Bug causing the regression]:1337276
[User impact if declined]:unable to fix the crash in bug 1338697.
[Is this code covered by automated tests?]:yes
[Has the fix been verified in Nightly?]:yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]:none
[Is the change risky?]:no
[Why is the change risky/not risky?]:The change is simple and verified in Nightly.
[String changes made/needed]:none
Attachment #8834277 - Flags: approval-mozilla-aurora?
Comment on attachment 8834277 [details]
Bug 1337276 - discard the audio request so we won't add audio samples to a finished queue.

Fix a audio playback issue. Aurora53+.
Attachment #8834277 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1338697
You need to log in before you can comment on or make changes to this bug.