Deccan Telugu does not work as expected on Firefox

RESOLVED DUPLICATE of bug 1325775

Status

()

Core
Graphics: Text
RESOLVED DUPLICATE of bug 1325775
10 months ago
10 months ago

People

(Reporter: Krasnaya Ploshchad’, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
Created attachment 8834302 [details]
Screenshot from Firefox

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

When I open Indian Type Foundry website, I found Deccan Telugu font does not works as expected.

Open https://www.indiantypefoundry.com/fonts/deccan-telugu to see it


Actual results:

న్ does not joining together with Deccan Telugu web font.


Expected results:

న్ should joining together as seen from Edge.
(Reporter)

Comment 1

10 months ago
Created attachment 8834304 [details]
Screenshot from Edge
I see this in Firefox 51, but AFAICT it works as expected in Dev Edition (53) and Nightly (54); I'm guessing this has been fixed in a harfbuzz update.

(You could bisect using mozregression --find-fix to confirm that.)

Comment 3

10 months ago
on OSX, the fix range is this:
  https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2a0ce9941af5823ae45d7dcd6af03fb00f6c3948&tochange=d6a2635d0bc51ccf79e000455f23a62ad6b17d3c
OK, thanks; so this is part of the HB 1.4.1 update -> resolving as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1325775
You need to log in before you can comment on or make changes to this bug.