Closed Bug 1337421 Opened 3 years ago Closed 3 years ago

Developer Tools Network Response blank starting in nightly 2017-01-19 (regression)

Categories

(Firefox :: Untriaged, defect)

53 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1333383

People

(Reporter: ohnobinki, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0 SeaMonkey/2.48
Build ID: 20170129141259

Steps to reproduce:

I visited a page (which I’m developing locally) which makes a POST request with an XHR to which it receives a JSON (application/json; charset=utf-8) response. I know that the response works because my page’s JavaScript gets the data and handles it fine. However, I wanted to quickly inspect the response.

To do so, I opened Developer Tools, went to the Network tab, performed activity on the page to cause the XHR to be sent again, clicked on the request in the list in the Network tab, and then clicked on the Response tab of the little request summary window thing that pops up.


Actual results:

I saw a blank pane inside of the Response tab (http://ftp.mozilla.org/pub/firefox/nightly/2017/01/2017-01-19-03-02-11-mozilla-central/): http://i.imgur.com/jjGM68O.png

Verified broken on http://ftp.mozilla.org/pub/firefox/nightly/2017/01/2017-01-31-03-02-05-mozilla-central/ . However, this appears to be fixed in the 2017-02-07 nightly. Could the fix be backported to Firefox-53?

An interesting thing you might notice when comparing the two screenshots is that the request in the request list is highlighted differently. When the Response tab doesn’t work, the request is not highlighted. However, by looking at the Headers tab, I have verified that the summary pop up window is showing information about the POST Get request which I selected.


Expected results:

I should have seen the response like I could with prior builds (http://ftp.mozilla.org/pub/firefox/nightly/2017/01/2017-01-18-03-02-14-mozilla-central/) http://i.imgur.com/20dhd23.png

As mentioned before, when the Response tab is working, the request in the request list shows up as highlighted dark blue so that you can actually tell that this request is the one that the summary pop up window is for.
After I had written most of this report, I noticed that it was fixed in nightly (2017-02-07). However, it is not fixed on the latest aurora release. If it can be verified that the fix in 54 is backported to 53 or that it will show up in aurora greatly, then I will be happy. Please mangle the bug title as necessary.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333383
You need to log in before you can comment on or make changes to this bug.