[RTL] Highlights introduction in Activity Stream lacks RTL

RESOLVED DUPLICATE of bug 1388377

Status

()

P2
normal
Rank:
3
RESOLVED DUPLICATE of bug 1388377
2 years ago
a year ago

People

(Reporter: itiel_yn8, Unassigned)

Tracking

(Blocks: 1 bug, {rtl})

unspecified
Unspecified
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55 affected)

Details

(Whiteboard: [MobileAS] 1.27)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8834457 [details]
Highlights introduction

STR:
1. Install Switchboard Experiments add-on on a FRESH installed Nightly
2. In about:experiments, tap on Activity stream
3. Settings -> Advanced -> Enable Activity stream
4. Open a New Tab
5. Observe the Highlights introduction.

AR:
It's not RTL-friendly.

ER:
a. The little fox and the globe image should be aligned to the left
b. The DISMISS button should be aligned to the right
c. The Highlights introduction should be aligned to the right

See attached screenshot (the introduction isn't shown there, it's probably due to a translation issue).

Comment 1

2 years ago
Created attachment 8874239 [details]
Screenshot of Nightly new tab

This bug reproduces on plain install of Nightly, and soon on every installation. Any chance to have it fixed? Changing the alignment to 'end' instead of 'right' could be a one-line change. 

UPDATED steps to reproduce:
a. Prerequisite: RTL locale of Android to an RTL locale or enable Android's Force RTL layouts on Settings → Developers.
b. Install Nightly or delete application data to have fresh start. 
c. Open new tab.

Updated

2 years ago
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox55: --- → affected
OS: Unspecified → Android

Comment 2

2 years ago
(In reply to Tomer Cohen :tomer from comment #1)
> UPDATED steps to reproduce:
> a. Prerequisite: RTL locale of Android to an RTL locale or enable Android's
> Force RTL layouts on Settings → Developers.

Alternative steps to reproduce:
Instead of having RTL locale on Android, you can also change the application language directly, but keep in mind that the profile should be clean.
Priority: -- → P2
Whiteboard: [MobileAS]
Iteration: --- → 1.27
Priority: P2 → P1
Whiteboard: [MobileAS] → [MobileAS] 1.27
bug 1388377 will change this UI around - we should do/verify the RTL afterwards.
Depends on: 1388377
Iteration: 1.27 → 1.28
Iteration: 1.28 → 1.29
Rank: 3
Priority: P1 → P2
This is for the empty state, and should only be shown once, so dropping this to P2 rank 3. (And it should probably just work)
Iteration: 1.29 → ---
This should just work after bug 1388377: it's only a TextView which should just work for RTL.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1388377
You need to log in before you can comment on or make changes to this bug.