Closed Bug 1337466 Opened 4 years ago Closed 4 years ago

mochitest layout/forms/test/test_bug549170.html is failing when run on ubuntu 16.04 vs 12.04

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: dholbert, Assigned: dholbert)

References

Details

Attachments

(1 file)

(Spinning this off of bug 1335885)

we are working on running all of our tests on ubuntu 16.04 vs 12.04, and there are some new failures to look at:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5ac0bd83bb7cd8ba2ecad1571c4d2038d8a70ba4&filter-searchStr=mochitest-e10s-8&selectedJob=73652332

TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | An inner div should be the target of the event - got "INPUT", expected "DIV"
TEST-UNEXPECTED-FAIL | layout/forms/test/test_bug549170.html | the target div should be the editor div
Flags: needinfo?(dholbert)
This patch fixes the issue for me -- just shifting the synthesized clicks 2px downwards & rightwards. (+1px isn't sufficient, but +2px is)

I'm pretty sure the problem is that the synthesized clicks are hitting the (curvier-on-recent-ubuntu) textarea/textfield-borders, and really they're intended to hit the actual inner editable area.

The current synthesized click target (5px, 5px from the element's origin) seems pretty arbitrary anyway, so I think 7px,7px is just as good and is a bit more reliably inside the textarea, apparently.
Flags: needinfo?(dholbert)
Comment on attachment 8835872 [details]
Bug 1337466: Adjust click position in test_bug549170.html to more reliably target editable area of textfield, rather than its border.

https://reviewboard.mozilla.org/r/111442/#review112764
Attachment #8835872 - Flags: review?(mats) → review+
Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ef9db85bfdd7
Adjust click position in test_bug549170.html to more reliably target editable area of textfield, rather than its border. r=mats
https://hg.mozilla.org/mozilla-central/rev/ef9db85bfdd7
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.