Allow users with many synced tabs to incrementally load more

RESOLVED DUPLICATE of bug 1244622

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1244622
10 months ago
9 months ago

People

(Reporter: rfeeley, Assigned: eoger)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
So that I don't strain my browser, as a multi-device Sync user with a ton of open tabs, I want to be able to Show More in the Synced Tabs menu.

X = Most recent 20 tabs
Y = Subsequent 20 recent tabs
Z = 5 oldest recent tabs

Show More (tooltip "Show more tabs from this device")
Show All (tooltip "Show all tabs from this device")
(Assignee)

Comment 1

10 months ago
Basically, when a user has 10k tabs, don't show 50 then 10k after clicking "Show all".
Instead, display a "Show More" button that loads 20 more tabs until we have displayed everything.
See Also: → bug 1244622

Comment 2

10 months ago
If we intend doing this sooner rather than later, shouldn't we just do this as part of bug 1244622?
(Assignee)

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244622
You need to log in before you can comment on or make changes to this bug.