undefined entity error on startup: &urlbar.extension.label;

RESOLVED DUPLICATE of bug 1342219

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 1342219
a year ago
a year ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

After migrating a profile from Firefox 51.0.1 (en-US build with active German language pack) to 54.0a1 (on Windows 8.1), only the yellow "undefined entity error" window popped up.

XML-Verarbeitungsfehler: Nicht definierte Entität
Adresse: chrome://browser/content/browser.xul
Zeile Nr. 2583, Spalte 17:                <label id="extension" class="urlbar-display urlbar-display-extension" value="&urlbar.extension.label;"/>
----------------^

This starts with bug 1267810:
https://hg.mozilla.org/mozilla-central/rev/02cecde2f137
https://hg.mozilla.org/mozilla-central/rev/007b565539fa

But it's racy, some test runs with newer builds didn't fail.

So for some reason Firefox fetches the strings from the incompatible and incomplete language pack.

Comment 1

a year ago
My suspicion is that this is a problem where language packs are not marked as incompatible.

Without doing actual research, this might be something that changed in the addons manager, so moving over there.
Component: General → Add-ons Manager
Product: Firefox → Toolkit
Once failed can you attach copies of extensions.ini and extensions.json from the profile folder. That will allow us to confirm that the locale pack is active and maybe why.
Flags: needinfo?(aryx.bugmail)
Created attachment 8834697 [details]
extensions.ini

The error message is in German, so the language pack is still active.
Flags: needinfo?(aryx.bugmail)
Very strange, the locale is there (as is the Spanish locale) and active yet the compatibility range means it shouldn't be. We've got lots of tests verifying that this sort of upgrade turns incompatible extensions off so I don't know what could be going on here.

Anything special about how you're switching from 51.0.1 to 54.0a1?
Flags: needinfo?(aryx.bugmail)
I clone the profile to a different folder and launch that (with -Profile), else nothing special. But the Session Manager addon shows a window on launch if I want to restore the session (likely it detects that I cloned the profile without the profile.lock file while it was being used) and the main browser window gets opened (with the error message) after that.

If I launch the cloned profile with 51.0.1, dismiss the session restore window, close 51.0.1 and launch 54.0a1, the issue is gone. The same applies to launching it with 51.0.1, confirming the session restore, quitting 51.0.1 and launching 54.0a1.
Flags: needinfo?(aryx.bugmail)

Comment 7

a year ago
can krupas' team reproduce this?
Flags: needinfo?(krupa.mozbugs)
Keywords: qawanted

Comment 8

a year ago
We've created a profile on FF 51.0.1, installed the German language pack and than opened it in Firefox 54.0a1. We couldn't reproduce the issue using this flow.

We also tried the following scenario. We created a profile on release, installed the German language pack and then we copied the entire profile content into a a new nightly profile. The issue couldn't be reproduce it using this flow.

We managed to obtain a similar result following this steps:
1. Open https://addons.allizom.org/en-US/firefox/addon/english-us-language-pack/ and install the language pack
2. Restart the browser 

The following error is displayed after restarting the browser: https://www.screencast.com/t/QSbgpiBX
Please note that this issue is reproducing only when installing a language pack from amo-stage.
Flags: needinfo?(krupa.mozbugs)

Comment 9

a year ago
retest after bug 1342219 lands - believe that will resolve.
Depends on: 1342219
Duplicate of this bug: 1348384
madalin,

can you retest this since bug 1342219 has landed?
Flags: needinfo?(madalin.cotetiu)

Comment 12

a year ago
(In reply to Madalin Cotetiu from comment #8)
> We've created a profile on FF 51.0.1, installed the German language pack and
> than opened it in Firefox 54.0a1. We couldn't reproduce the issue using this
> flow.
> 
> We also tried the following scenario. We created a profile on release,
> installed the German language pack and then we copied the entire profile
> content into a a new nightly profile. The issue couldn't be reproduce it
> using this flow.

I have rechecked this and I still can't reproduce it.



> 
> We managed to obtain a similar result following this steps:
> 1. Open
> https://addons.allizom.org/en-US/firefox/addon/english-us-language-pack/ and
> install the language pack
> 2. Restart the browser 

Also I have retested this issue and now I can't no longer install https://addons.allizom.org/en-US/firefox/addon/english-us-language-pack/  (The message that the language pack is not compatible is displayed correctly and the add-on can't be installed)
Flags: needinfo?(madalin.cotetiu)
You should install it from here:

https://addons.mozilla.org/en-US/firefox/addon/english-us-language-pack/

That is the test add-ons side, so it is stuck at an older version.

Comment 14

a year ago
(In reply to Mike Kaply [:mkaply] from comment #13)
> You should install it from here:
> 
> https://addons.mozilla.org/en-US/firefox/addon/english-us-language-pack/
> 
> That is the test add-ons side, so it is stuck at an older version.

Installing from the production site works well, there are no issue in there. I have tried with the specified German language pack and the English language pack. I have mentioned the stage environment because that was the only place where we encountered a similar issue.

Updated

a year ago
Flags: needinfo?(amckay)

Comment 15

a year ago
It sounds like based on comment 14 and 12 this is now fixed and can probably be duped to the bug mentioned in comment 9.
Flags: needinfo?(amckay)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1342219
Considering that this bug was marked as duplicate, I am removing the qawanted keyword.
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.