If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Website states an improper date

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
8 months ago
7 months ago

People

(Reporter: eryan, Unassigned)

Tracking

({testcase-wanted})

51 Branch
testcase-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125172221

Steps to reproduce:

Tested different versions of Firefox over different days to find which versions included the bug (45.3.0 and forward) and which ones didn't (45.2.0 and previous). Checked after a day to see if the internal mediawiki this is happening on updated the time correctly until I found the version that performed without any bugs. Tested this occurrence on other browsers to see if the issue occurred there too. It only happens in Firefox, so we know it's not an issue with the mediawiki.


Actual results:

There appears to be a caching problem introduced in 45.3.0 (after testing with 45.2.0 the issue was not shown). The date remains 'stuck' on the date that the website was first visited with Firefox. Incognito mode on the afflicted versions shows the correct date which is why I think it has to do with caching.


Expected results:

I expected the website to update to the current, correct date each time the website was visited.

Comment 1

7 months ago
URL of the website? Steps to reproduce the caching issue?
Flags: needinfo?(eryan)
(Reporter)

Comment 2

7 months ago
The website is an internal Wiki that's inaccessible to hosts outside of our IP range. The only thing I had to do to reproduce the issue was load the page one day and return to it the next, at that point I saw that the date had not updated since the previous day.
(Reporter)

Updated

7 months ago
Flags: needinfo?(eryan)

Comment 3

7 months ago
Without testcase, it will hard to test and debug unfortunately.
Keywords: testcase-wanted
(Reporter)

Comment 4

7 months ago
Looks like this issue was resolved in 51.0.1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.