rowspan table cell content not displayed

VERIFIED FIXED in mozilla1.0

Status

()

Core
Layout: Tables
P2
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Sven Oertmann, Assigned: karnaze (gone))

Tracking

({dataloss, regression, testcase})

Trunk
mozilla1.0
x86
All
dataloss, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3]PATCH, URL)

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
See URL www.free2talk.de with Mozilla 0.9.9 (Build 2002032603) and Internet 
Explorer. The image map is neither able to click on it as not even able to see 
in Mozilla.

The webmaster of free2talk can ensure that when he have coded it that he have 
tested it before also with Mozilla and it was working fine. But at that current 
version of Mozilla he confirms me that it is also not displayed on his 
computer - he is using Windows XP with the same build now (downloaded today).
(Reporter)

Comment 1

16 years ago
Created attachment 76415 [details]
Image Map ... view+clickable on Explorer - not at Mozilla

Comment 2

16 years ago
reassigning.
Assignee: morse → pavlov
Component: Image Management → ImageLib
QA Contact: tever → tpreston
(Reporter)

Comment 3

16 years ago
Created attachment 76417 [details]
Netscape 6.21 is doing it correctly

On that image of Netscape 6 can see that it must have worked on Mozilla before,
too. I have read that Netscape 6.2.2 shall base on Mozilla 0.9.4 - dunno if
true or not. But I also think that with my 0.9.7 it was working fine, just now
seems that function is missing.

Comment 4

16 years ago
-> layout
Assignee: pavlov → attinasi
Component: ImageLib → Layout
QA Contact: tpreston → petersen

Comment 5

16 years ago
Changing QA contact
QA Contact: petersen → amar

Comment 6

16 years ago
Created attachment 76443 [details]
minimal testcase

attaching minimal testcase

not sure if what mozilla is doing is OK or not - it appears that it doesn't
like the rowspan with the empty rows.  I don't think it's valid HTML for there
not to be at least one <td></td> within each row, and inserting them where
indicated (comments in the testcase) makes it work as expected.

Comment 7

16 years ago
confirming, testcase, updating summary. leaving OS as win98, but it happens 
with win2000 for me (with a recent nightly), so i guess is probably "all"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Summary: Image Map not displayed with Mozilla 0.9.9 → rowspan table cell content not displayed

Comment 8

16 years ago
Created attachment 76498 [details]
More testcases

Comment 9

16 years ago
Also occurs on Linux, OS->All. Reassigning to HTMLTables.
Assignee: attinasi → karnaze
Component: Layout → HTMLTables
Keywords: regression
OS: Windows 98 → All
(Assignee)

Comment 10

16 years ago
I think this bug has existed for a few months.
Severity: normal → major
Status: NEW → ASSIGNED
Keywords: dataloss, nsbeta1
Priority: -- → P2
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 11

16 years ago
Created attachment 76518 [details] [diff] [review]
patch to fix the bug

Updated

16 years ago
Whiteboard: [adt3]

Comment 12

16 years ago
Comment on attachment 76518 [details] [diff] [review]
patch to fix the bug

r= alexsavulov
Attachment #76518 - Flags: review+

Updated

16 years ago
Attachment #76518 - Flags: superreview+

Comment 13

16 years ago
Comment on attachment 76518 [details] [diff] [review]
patch to fix the bug

sr=attinasi
Comment on attachment 76518 [details] [diff] [review]
patch to fix the bug

a=roc+moz
Attachment #76518 - Flags: approval+
(Assignee)

Updated

16 years ago
Whiteboard: [adt3] → [adt3]PATCH
(Assignee)

Comment 15

16 years ago
The patch is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
 Verified. The attached testcases and the given URL works fine. 
Build ID: 2002041003
Status: RESOLVED → VERIFIED

Comment 17

16 years ago
*** Bug 111191 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.