User is redirected to homepage after changing language

RESOLVED WONTFIX

Status

support.mozilla.org - Lithium
Localization
P2
normal
RESOLVED WONTFIX
9 months ago
4 months ago

People

(Reporter: zelitomas, Assigned: vesper)

Tracking

Details

(Whiteboard: [1st2weeks])

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170126153126

Steps to reproduce:

On a page with localized support article (for  example https://support.mozilla.org/t5/Z%C3%A1kladn%C3%AD-prohl%C3%AD%C5%BEen%C3%AD/Webov%C3%A1-ozn%C3%A1men%C3%AD-ve-Firefoxu/ta-p/38227) click on the language selector in top right corner. Then select different language (in my case English)


Actual results:

I got redirected to homepage in selected language (https://support.mozilla.org/t5/Mozilla-Support-English/ct-p/Mozilla-EN)


Expected results:

Same article in selected language should be opened (https://support.mozilla.org/t5/Basic-Browsing/Web-Push-notifications-in-Firefox/ta-p/28744 in this case)
(Assignee)

Updated

9 months ago
Whiteboard: [1st2weeks]
(Assignee)

Comment 1

9 months ago
Thanks for reporting this, Tomas.

Due to the platform's current limitations, this is an expected behaviour. We will be introducing a component on the article page (in the side bar) that will allow you to switch to other language versions of the viewed article (if they exist and are linked using the English article ID tag).

More information on this soon, hopefully. We had the component ready in testing, but string encoding issues made for a bad user experience, so we decided to not launch with it and add it when it's fixed.

Updated

7 months ago
Component: Localization → Localization
Product: support.mozilla.org → support.mozilla.org - Lithium
(Assignee)

Updated

5 months ago
Assignee: nobody → mdziewonski
(Assignee)

Updated

5 months ago
Depends on: 1347965
Priority: -- → P2
(Assignee)

Comment 2

4 months ago
Marking as WONTFIX - more details here: https://blog.mozilla.org/sumo/2017/06/28/important-platform-update/
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.