Closed Bug 1337667 Opened 4 years ago Closed 3 years ago

re-enable disabled xpcshell tests in stylo builds

Categories

(Core :: CSS Parsing and Computation, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: heycam, Assigned: chmanchester)

References

Details

Attachments

(2 files)

In the incubator/stylo repo, but not on mozilla-central, we have a few xpcshell tests in testing/xpcshell/selftest.py that are disabled due to crashes.
Priority: -- → P3
So, I just realized that this may block building stylo by default, because these tests are currently disabled at build time, which means that building stylo by default will turn these tests off everywhere.

I just tried re-enabling them, and they still fail. Not sure why: https://treeherder.mozilla.org/#/jobs?repo=try&revision=2f06c47467c546fc7e9801d7daf87eb380dd586f&selectedJob=99074518

ted, cmanchester: Any idea what's going on here?
Blocks: stylo-nightly-build
No longer blocks: stylo
Flags: needinfo?(ted)
Flags: needinfo?(cmanchester)
Summary: stylo: re-enable disabled xpcshell tests → re-enable disabled xpcshell tests in stylo builds
Priority: P3 → P1
I tried to investigate this for a bit, but wasn't able to find the cause before having to stop for today...

The test in question is `testing/xpcshell/selftest.py`, which appears to crash when running `testChild` for Stylo builds.

With a local Linux 64-bit Stylo build, the test passes just fine.

I was able to replicate the failure using a "one click loaner" of :bholley's try build above.  You can trigger the error in the loaner's shell using:

```
cd workspace/build/src
. obj-firefox/_virtualenv/bin/activate
export LD_LIBRARY_PATH="obj-firefox/dist/bin:/home/worker/workspace/build/src/clang/lib:/home/worker/workspace/build/src/gtk3/usr/local/lib:/home/worker/workspace/build/src/clang/lib:/home/worker/workspace/build/src/gtk3/usr/local/lib"
export MINIDUMP_STACKWALK="/home/worker/workspace/build/tools/breakpad/linux64/minidump_stackwalk"
./testing/xpcshell/selftest.py
```

My next step was going to be running the same thing under a debugger (gdb and such can be installed via yum on the loaner).  I can take another look tomorrow if there's no other progress here.
I added a sleep hack[1] to `xpcshell` so I would be able to attach with gdb after it's launched from the test.

Once I attached, I tried to continue in gdb, but I got:

(gdb) c
Continuing.
Warning:
Cannot insert breakpoint -1.
Error accessing memory address 0x7f30a0b65e10: Input/output error.
Cannot insert breakpoint -2.
Error accessing memory address 0x7f30a0b65e20: Input/output error.
Cannot insert breakpoint -11.
Error accessing memory address 0x7f30a0d80987: Input/output error.
Cannot insert breakpoint -13.
Error accessing memory address 0x7f30a0d8ff24: Input/output error.
Cannot insert breakpoint -15.
Error accessing memory address 0x7f30a0d9138b: Input/output error.

At this point, I don't know how to proceed, so I'll leave this to ted / cmanchester to investigate.

[1]: http://searchfox.org/mozilla-central/rev/ae24a3c83d22e0e35aecfd9049c2b463ca7e045b/toolkit/xre/nsEmbedFunctions.cpp#550-561
This looks like an issue with the stylo build Taskcluster configs.
Assignee: nobody → cmanchester
Flags: needinfo?(ted)
Flags: needinfo?(cmanchester)
Comment on attachment 8868724 [details]
Bug 1337667 - Add need-xvfb to stylo build Taskcluster configs.

https://reviewboard.mozilla.org/r/140322/#review143648
Attachment #8868724 - Flags: review?(dustin) → review+
Comment on attachment 8868725 [details]
Bug 1337667 - Un-skip xpcshell selftests for stylo now that they're passing.

https://reviewboard.mozilla.org/r/140324/#review144126

Assuming they do indeed pass now, I don't think we need to wait on review from :ted specifically.
Attachment #8868725 - Flags: review+
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7a4f7c560279
Add need-xvfb to stylo build Taskcluster configs. r=dustin
https://hg.mozilla.org/integration/autoland/rev/a3c94d0130ef
Un-skip xpcshell selftests for stylo now that they're passing. r=jryans
https://hg.mozilla.org/mozilla-central/rev/7a4f7c560279
https://hg.mozilla.org/mozilla-central/rev/a3c94d0130ef
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Comment on attachment 8868725 [details]
Bug 1337667 - Un-skip xpcshell selftests for stylo now that they're passing.

https://reviewboard.mozilla.org/r/140324/#review149898
Attachment #8868725 - Flags: review?(ted) → review+
You need to log in before you can comment on or make changes to this bug.