file uploads are showing up in _post method as well as _files

VERIFIED DUPLICATE of bug 133453

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 133453
17 years ago
16 years ago

People

(Reporter: ken spencer, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313
BuildID:    2002031312

When a form is posted with a blank input type=file
it is posted in the _post method insted of ignored. 
This is causing a number of scripting issues for me.

Reproducible: Always
Steps to Reproduce:
See description

Comment 1

17 years ago
I'm experiencing this, too.  With Mozilla 0.9.9, an empty file upload box, 
submitted with enctype="multipart/form-data" to a Java servlet running under 
Tomcat (using com.oreilly.servlet to parse the form data), causes the servlet 
to get an empty string parameter.  This doesn't occur with Mozilla 0.9.8, 
Netscape 4.7 or Konqueror; with those browsers, the servlet either gets a file 
parameter containing data, or nothing at all.

Comment 2

16 years ago
-> Form Submission
Assignee: law → alexsavulov
Component: File Handling → Form Submission
QA Contact: sairuh → vladimire

Comment 3

16 years ago
I think this is a dupe of the old file upload bug that was breaking ebay..

*** This bug has been marked as a duplicate of 133453 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.