Intermittent browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js | recording-device-events notification unexpected - Got -1, expected 0

RESOLVED DUPLICATE of bug 1363253

Status

()

P2
normal
Rank:
25
RESOLVED DUPLICATE of bug 1363253
2 years ago
8 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell fixed])

Attachments

(1 attachment)

20 failures in 836 pushes (0.024 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* mozilla-inbound: 9
* autoland: 5
* mozilla-central: 3
* mozilla-aurora: 3

Platform breakdown:
* windows8-64: 18
* windows7-32-vm: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-02-06&endday=2017-02-12&tree=all
Rank: 25
Priority: -- → P2
See Also: → bug 1320994
These failures started after the fix in bug 1323880 landed.

Several of these failures were associated to bug 1324303.
Blocks: 1323880
See Also: → bug 1324303
20 failures in 833 pushes (0.024 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* mozilla-inbound: 9
* autoland: 5
* mozilla-central: 3
* mozilla-aurora: 3

Platform breakdown:
* windows8-64: 14
* windows7-32-vm: 4
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-02-13&endday=2017-02-19&tree=all
35 failures in 812 pushes (0.043 failures/push) were associated with this bug in the last 7 days. 

This is the #48 most frequent failure this week. 

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **

Repository breakdown:
* mozilla-inbound: 15
* autoland: 12
* mozilla-aurora: 4
* mozilla-central: 3
* try: 1

Platform breakdown:
* windows8-64: 30
* windows7-32-vm: 3
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-02-20&endday=2017-02-26&tree=all
:florian, can you take a look at fixing this or helping find somebody to look at this?
Flags: needinfo?(florian)
Whiteboard: [stockwell needswork]
(In reply to Joel Maher ( :jmaher) from comment #5)
> :florian, can you take a look at fixing this or helping find somebody to
> look at this?

I can investigate a bit. But given how often bug 1324303 occurs, and given that I don't see any progress on fixing bug 1320994, it may be time to start writing code to make the test skip the recording-device-events notification check on some platforms; so that we keep most of the coverage but stop being bothered by the intermittent behavior.
Flags: needinfo?(florian)
both bug 1324303 and this one are past our 30/week threshold where we want to see a fix.  This bug fails on win8 primarily and bug 1324303 more on linux.  What help would you need in this?  These failures have been constant for 2+ weeks :(
Andreas, is there any chance of seeing progress in bug 1320994 soon, or should we write code to skip the recording-device-events notification check on Windows64 and Linux?
Flags: needinfo?(pehrson)
I'm a bit swamped at the moment but I can prioritise it and take a look in a week or so.
Flags: needinfo?(pehrson)
Depends on: 1320994
See Also: bug 1320994
Thanks Andreas for pointing at a root cause- I understand you are busy- if we focus on the root cause, can we partially disable this in the mean time and add a comment to bug 1320994 to ensure that we backout the disabling?
The biggest problem with that is that it might never get fixed since it's not an immediate problem anymore. There are always other problems that seem immediate, and suddenly you've forgotten about it. I guess it's up to you to weigh the cost of keeping it around for another two something weeks against keeping it around for a much longer time.
30 failures in 783 pushes (0.038 failures/push) were associated with this bug in the last 7 days. 

This is the #43 most frequent failure this week. 

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. **

Repository breakdown:
* mozilla-inbound: 13
* autoland: 11
* try: 2
* mozilla-central: 2
* mozilla-aurora: 2

Platform breakdown:
* windows8-64: 23
* windows7-32-vm: 5
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-02-27&endday=2017-03-05&tree=all
12 failures in 790 pushes (0.015 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-aurora: 4
* autoland: 4
* mozilla-beta: 2
* mozilla-inbound: 1
* mozilla-central: 1

Platform breakdown:
* windows8-64: 9
* windows7-32-vm: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-03-06&endday=2017-03-12&tree=all
Created attachment 8847189 [details] [diff] [review]
disable test on linux debug and win opt/pgo

when there is time to fix this we hope to see this enabled again soon!
Attachment #8847189 - Flags: review?(gbrown)
this will fix this for bug 1324303 as well.

Updated

2 years ago
Attachment #8847189 - Flags: review?(gbrown) → review+

Comment 16

2 years ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a37f9e1cbc8f
Intermittent browser/base/content/test/webrtc/browser_devices_get_user_media_screen.js. r=gbrown
Keywords: leave-open
Whiteboard: [stockwell needswork] → [stockwell disabled]
14 failures in 777 pushes (0.018 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-aurora: 5
* autoland: 4
* mozilla-central: 2
* mozilla-beta: 2
* mozilla-inbound: 1

Platform breakdown:
* windows8-64: 11
* windows7-32-vm: 2
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-03-13&endday=2017-03-19&tree=all
5 failures in 867 pushes (0.006 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 4
* mozilla-aurora: 1

Platform breakdown:
* windows8-64: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-04-03&endday=2017-04-09&tree=all
14 failures in 894 pushes (0.016 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-aurora: 6
* try: 3
* mozilla-beta: 3
* mozilla-release: 2

Platform breakdown:
* windows8-64: 13
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-04-10&endday=2017-04-16&tree=all
7 failures in 770 pushes (0.009 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 5
* autoland: 2

Platform breakdown:
* windows8-64: 5
* windows7-32-vm: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-05-01&endday=2017-05-07&tree=all
30 failures in 879 pushes (0.034 failures/push) were associated with this bug in the last 7 days. 

This is the #46 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 13
* mozilla-inbound: 12
* oak: 3
* mozilla-central: 1
* graphics: 1

Platform breakdown:
* windows8-64: 25
* windows7-32-vm: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-05-08&endday=2017-05-14&tree=all
I have patches on bug 1363253 that I hope will fix this.
See Also: → bug 1363253
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1363253
Whiteboard: [stockwell disabled] → [stockwell fixed]
10 failures in 777 pushes (0.013 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 3
* autoland: 3
* oak: 1
* mozilla-release: 1
* mozilla-central: 1
* graphics: 1

Platform breakdown:
* windows8-64: 8
* windows7-32-vm: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1338038&startday=2017-05-15&endday=2017-05-21&tree=all
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.