Closed Bug 1338083 Opened 4 years ago Closed 4 years ago

Unnecessary change of visit date format in Library. The change makes user confusing.

Categories

(Firefox :: Bookmarks & History, defect, P1)

52 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 54
Tracking Status
firefox-esr45 --- unaffected
firefox51 --- unaffected
firefox52 + verified
firefox-esr52 --- fixed
firefox53 + verified
firefox54 + verified

People

(Reporter: alice0775, Assigned: mak)

References

Details

(Keywords: regression, ux-consistency)

Attachments

(3 files)

Attached image Screenshot en-US
[Tracking Requested - why for this release]: Unnecessary change of visit date format in Library.  The change makes user confusing.

Steps To Reproduce:
1. Open Show All History
2. Add Most Recent Visit

Actual Results:
Visit date format in Library is changed since beta52

Expected Results:
Do not perform unnecessary changes in appearance confusing users.
Visit date format in Library  should be same results between Firefox51.0.1 and Beta52.0b4


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d523f32cf87f2122fbbca86e0e3d2d0a26942ab6&tochange=686282bd2f19b5f0ab249cde34caea04fc5c17a1

Regressed by: Bug 1301655
Attached image Screenshot ja
Flags: needinfo?(jfkthame)
The regression is likely in https://hg.mozilla.org/mozilla-central/rev/68543a46ef49
Likely in _dateFormatter, year: '2-digit' should surely be changed to full year, and uplifted.
The rest is opinable, looks like we were using a sort-of ISO 8601 date, but with slashes. I'd suggest to be consistent with the most common UI our users may be used to see, that is Windows Explorer.
[Tracking Requested - why for this release]:
Priority: -- → P1
Component: Places → Bookmarks & History
Product: Toolkit → Firefox
I was looking at various Explorer sshots around.
Looks like in ja we want YYYY/MM/DD HH:MM while in en-us MM/DD/YYYY HH:MM AM

Based on the screenshots, the only thing we should change is the 4digits year.
I'll just attach a patch.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Flags: needinfo?(jfkthame)
Yes, it should be a 4-digit year. (Apparently that's what we were getting from Ci.nsIScriptableDateFormat.dateFormatShort despite the "short" part of its name...)

Thanks for taking care of this, Marco.
Comment on attachment 8835381 [details]
Bug 1338083 - Restore full year in Library date columns.

https://reviewboard.mozilla.org/r/111070/#review112330
Attachment #8835381 - Flags: review?(jfkthame) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/6db943216f7e
Restore full year in Library date columns. r=jfkthame
Tracking for all branches. Once this is fixed, please request uplift if you want this patch on 52 before we ship.

Thanks Alice for filing the bug and mak for fixing it.
https://hg.mozilla.org/mozilla-central/rev/6db943216f7e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Comment on attachment 8835381 [details]
Bug 1338083 - Restore full year in Library date columns.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1301655
[User impact if declined]: Dates in the Library are hard to read and may confuse users
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: not yet, nightly will be available in a few hours.
[Needs manual test from QE? If yes, steps to reproduce]: yes, it's trivial to verify by just looking at the Library, showing a date column and checking the year is full 4 digit
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: just changing year format from 2-digit to full year
[String changes made/needed]: none
Attachment #8835381 - Flags: approval-mozilla-beta?
Attachment #8835381 - Flags: approval-mozilla-aurora?
Verified Fixed in Nightly 20170210030206
Status: RESOLVED → VERIFIED
Comment on attachment 8835381 [details]
Bug 1338083 - Restore full year in Library date columns.

revert recent unintentional UI change in aurora53, beta52
Attachment #8835381 - Flags: approval-mozilla-beta?
Attachment #8835381 - Flags: approval-mozilla-beta+
Attachment #8835381 - Flags: approval-mozilla-aurora?
Attachment #8835381 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
QA Contact: timea.zsoldos
I have reproduced this issue using Firefox 52.0b4 (20170206101855) on Win 8.1 x64.
I can confirm this issue is fixed, I verified using Firefox 52.0b6 and 53.0a2 on Win 8.1 x64, Ubuntu 16.04 x64 and Mac OS X 10.11.
Flags: in-testsuite+
QA Contact: timea.zsoldos
You need to log in before you can comment on or make changes to this bug.