In about:preferences while choosing search engines, keyboard shortcuts don't work properly

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
8 months ago
8 months ago

People

(Reporter: aakashg57, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(firefox51 affected, firefox52 affected, firefox53 affected, firefox54 affected)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170208030203

Steps to reproduce:

Go to about:preferences -> search -> Default search engine : There is a dropdown for selecting Default search engine, if we use keyboard to select that element and press a key like 'G' then Google is selected, 'W' selects Wikipedia, 'D' selects Duckduckgo and so on


Actual results:

Sometimes, the search engine is selected sometimes it is not when pressing a Key of the Initial letter of the search engine


Expected results:

When pressing a key on the keyboard, the search engine corresponding to the key pressed should be selected
I also see the issue with the latest Nightly if I press the key shortly after I pressed the previous one. But in that case, it's like typing the second letter of the search engine (e.g. when people have added search engines or in some localized builds, there might be search engines starting with the same letter).

Do you also see the issue if you wait at least 2 seconds between the keypresses?
Component: Untriaged → Preferences
Flags: needinfo?(aakashg57)

Updated

8 months ago
Summary: In about:preferences while choosing search engines, keyboard shortcuts donot work properly → In about:preferences while choosing search engines, keyboard shortcuts don't work properly

Comment 2

8 months ago
The issue is in FF51 too.

Comment 3

8 months ago
reg range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=29e262587b6bfca2dec20265ffa7874410355c40&tochange=6e0788aa97c74aa11b75654bfc82d4ecb34f502a

Florian Quèze — Bug 1260820 - Search engine drop down closes when I change search engines by pressing Up/Down, r=Gijs.
Blocks: 1260820
Status: UNCONFIRMED → NEW
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox54: --- → affected
Ever confirmed: true
Flags: needinfo?(aakashg57) → needinfo?(florian)
OS: Unspecified → All
Hardware: Unspecified → All
Version: 54 Branch → 48 Branch
Loic, do you see a problem if you wait more than 1s between each keypress? (1s is the value at http://searchfox.org/mozilla-central/rev/afcf40f3eafd895611a839017730debb58a342a6/toolkit/content/widgets/listbox.xml#604)
Flags: needinfo?(florian) → needinfo?(epinal99-bugzilla2)

Comment 5

8 months ago
No.
Flags: needinfo?(epinal99-bugzilla2)
I think this is working as designed then. Thanks!
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.