Closed Bug 1338116 Opened 4 years ago Closed 4 years ago

Places favicon (bookmarks, history) incorrectly uses larger icon size

Categories

(Toolkit :: Places, defect)

51 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 492172

People

(Reporter: public, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

On a Windows computer with a normal 100% DPI display, visit a site such as https://www.microsoft.com/ or https://deskthority.net/ where the favicon contains both normal (16×16) and one or more larger sizes. Bookmark the site, or locate the site in the history tab.


Actual results:

The tab correctly uses the 16×16 icon size, as expected for a 100% DPI mode. The bookmark, history pane, and history autocomplete all use the larger icon, scaled down to 16×16. Some icon designs, such as those with straight edges, need to be tuned to each size, and the use of the wrong size results in a blurred icon due to the scaling.


Expected results:

The algorithm used to choose the size for tabs, should still be used for the Places subsystem (bookmarks and history).

If I recall correctly, this is a regression as of Firefox 51. Possibly 50, but no earlier.
Component: Activity Streams: General → Places
Product: Firefox → Toolkit
we don't have support for hi res favicons in history/bookmarks, we are adding it.

The tab uses the image that comes from the network, while other views use an image stored locally, that's why they are and will keep being different.
In the future we'll try to make better choices, but all of that depends on hires favicons support.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: PlacesHiresFavicons
You need to log in before you can comment on or make changes to this bug.