WebGL 2.0 fails to display in Firefox 51.0.1 on late 2009 iMac running OS X Sierra 10.12.3

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: olivier.debroqueville, Unassigned)

Tracking

51 Branch
Unspecified
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted, URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8835495 [details]
firefox-about-support.rtf

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/602.4.8 (KHTML, like Gecko) Version/10.0.3 Safari/602.4.8

Steps to reproduce:

I tried to display the following web page in Firefox 51.0.1:
https://playcanv.as/e/p/44MRmJRU/


Actual results:

I got a black background in Firefox with the following error message displayed in red: "This demo requires WebGL 2.0 support. Please update to the latest version of Mozilla Firefox."


Expected results:

I should have seen a web page with WebGL 2.0 content!
(Reporter)

Updated

2 years ago
Severity: normal → blocker
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
> WebGL Renderer: ATI Technologies Inc. -- ATI Radeon HD 4850 OpenGL Engine
> WebGL2 Renderer: WebGL creation failed: * WebGL 2 requires support for the following features: transform_feedback2 * Exhausted GL driver options.

I think we unfortunately just can't support it there. Does Chrome 56 support WebGL 2 on this machine?
Severity: blocker → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(olivier.debroqueville)
Whiteboard: gfx-noted
Hardware: x86_64 → Unspecified
I think HD4850 is just too old to support WebGL2.

WebGL2 is based on OpenGL ES3 released in 2012.

And 4850 is released in 2008, which is 4 years older.
(Reporter)

Comment 3

2 years ago
@jgilbert : WebGL 2.0 doesn't work in Chrome Version 56.0.2924.87 (64-bit) either.

I think this clearly means WebGL 2.0 isn't supported on late 2009 iMacs (and probably any iMac older than 2012) and, unfortunately, Apple doesn't build modular systems where a user could easily upgrade a module, e.g. a graphics card. Apple prefers to promote programmed obsolescence and force its customers to buy a new computer ever now and then! Looks like I'm going to have to skip WebGL 2.0!
Flags: needinfo?(olivier.debroqueville)
(In reply to olivier.debroqueville from comment #3)
> @jgilbert : WebGL 2.0 doesn't work in Chrome Version 56.0.2924.87 (64-bit)
> either.
> 
> I think this clearly means WebGL 2.0 isn't supported on late 2009 iMacs (and
> probably any iMac older than 2012) and, unfortunately, Apple doesn't build
> modular systems where a user could easily upgrade a module, e.g. a graphics
> card. Apple prefers to promote programmed obsolescence and force its
> customers to buy a new computer ever now and then! Looks like I'm going to
> have to skip WebGL 2.0!

That's a bummer, but looks like it!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.