entering invalid/bogus passwd. for ftp publish gives bad filename in Publish progress panel

VERIFIED DUPLICATE of bug 130536

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 130536
16 years ago
13 years ago

People

(Reporter: sujay, Assigned: Charles Manske)

Tracking

Trunk
mozilla1.1alpha

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: publish)

(Reporter)

Description

16 years ago
using 3/27 build of netscape

1) launch netscape
2) launch composer
3) enter some text
4) publish to an ftp server(with username "anonymous", page title, filename -
foo.html,
sitename). 
5) Leave Password field blank
6) publish

it'll prompt you for a passwd., give it ";sljfs" or some garbage

now look at the filename in the publish progress panel. It looks like
this: "foo.htm%20!"

Comment 1

16 years ago
Sujay--what did you name the file you were publishing?  It looks like you tried
"foo.htm "  Is this publishing to marvin or some other ftp server?

The "bogus password" shouldn't be relevant at all.  Do you see the same problem
if you use "cat;dog;cow"?

I need more info to understand this bug.
Keywords: nsbeta1
Whiteboard: publish
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

16 years ago
If you want to use anonymous login, then you must use
"anonymous" as username and your email address as password. 
I don't know if leaving password blank is acceptable.
Doug? Bradley?
I don't think we should worry much about anonymous publishing.
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla1.1alpha
Not accepting a blank password is an issue I actually have a bug on - bug
130536. Its a simple fix, but the server has to be configured to accept that, so
it probably won't help you.

I still think that the composer publishing code should just require a username
and a password. Then we can worry about how to fix ftp to let the caller handle
this later, after 1.0
(Assignee)

Comment 4

16 years ago
Bradley: 
I agree with you; Composer DOES try to force the user to enter a username and 
password before it publishes, but after we publish, we change to editing the 
remote url.
If user has not supplied an HTTP alias in Settings panel, we are in a world of
pain -- see bug 133823.
It seems like the original description really makes this a dup.

*** This bug has been marked as a duplicate of 130536 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

16 years ago
ok blank passwd. is covered by another bug...how about bogus passwd. though ?
like something other than an email address...?
(Assignee)

Comment 6

16 years ago
Then we die with "Login incorrect" :(
(Reporter)

Comment 7

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.