Closed Bug 133835 Opened 20 years ago Closed 6 years ago

symlinks should use generic symlink icons

Categories

(Core :: Networking: FTP, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: sebastian_kapfer, Unassigned)

References

()

Details

This problem seems to be similar to Bug #124134; I can't reproduce that one
however (my platform: Linux, Mozilla 0.9.9, 2002031312).

Reproduction:
Have a look the FTP directory ftp://ftp.gnu.org/gnu/.
For example, the links "GPL" and "LGPL" are displayed als folders in HTML mode,
even though they point to text files.

(XUL mode shows all links as plain files BTW. Maybe there should be a dedicated
icon for links.)
related: bug 39785
They're in italics, to represent a link. How can mozilla know whether its a link
to a file or to a directory?
this is INVALID no?

mozilla has no way of knowing whether it's a link to a file or a directory
It may be difficult to figure out. But Mozilla could at least use a separate
icon for links, to indicate "I don't know what it is".
We may be able to parse it, and see if the linked-to dir shows with a /.

Any suggestions for an icon?

-> future, though
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Target Milestone: --- → Future
> Any suggestions for an icon?

Take a look at the icons that come with Apache. They're all public 
domain so you can't get into too much trouble.
Summary: FTP links to files displayed as directories → FTP links to files that are soft links use directory icons
I think this bug is fixed in Mozilla 1.0.
It displays those GPL files as links.
Still doesn't work for me (1.0, Linux, 2002052918). Do you have a later version?

NB: I was complaining about the icon being a folder icon. I think this is
misleading, and a separate icon for links (both directories and plain files)
should be used.

And yes, I know that italic names indicate links :)
If someone could submit a "link icon" here, that would be helpful.

I have no time to work on mozilla at the moment, so dougt is taking over FTP

open ftp bugs -> him
Assignee: bbaetz → dougt
Summary: FTP links to files that are soft links use directory icons → all soft links use directory icons, even for files
*** Bug 39785 has been marked as a duplicate of this bug. ***
OS: Linux → All
Hardware: PC → All
*** Bug 225093 has been marked as a duplicate of this bug. ***
*** Bug 314584 has been marked as a duplicate of this bug. ***
mass reassigning to nobody.
Assignee: dougt → nobody
Severity: trivial → enhancement
Keywords: helpwanteduiwanted
Summary: all soft links use directory icons, even for files → symlinks should use generic symlink icons
Sure. No particular opinion on how we handle this.
Keywords: uiwanted
no more ftp changes except for critical fixes
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.