Closed Bug 1338444 Opened 3 years ago Closed 3 years ago

cmath:638:9: error: '::signbit' has not been declared 0:00.46 using ::signbit; with --with-android-version=21

Categories

(Core :: Internationalization, defect, P3)

Unspecified
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1345762
Tracking Status
firefox54 --- affected

People

(Reporter: m_kato, Assigned: m_kato)

References

(Blocks 1 open bug)

Details

When using --with-android-version=21, building OSPreference_unix.cpp causes the following error.

 0:00.46 In file included from /mozilla/objdir-android/dist/system_wrappers/cmath:3:0,
 0:00.46                  from /mozilla/objdir-android/dist/stl_wrappers/cmath:44,
 0:00.46                  from /mozilla/objdir-android/dist/include/mozilla/MathAlgorithms.h:15,
 0:00.46                  from /mozilla/objdir-android/dist/include/nsTArray.h:16,
 0:00.46                  from /mozilla/mobile/intl/locale/OSPreferences.h:11,
 0:00.46                  from /mozilla/mobile/intl/locale/unix/OSPreferences_unix.cpp:7:
 0:00.46 /home/makoto/bin/android-ndk-r12b/sources/cxx-stl/llvm-libc++/libcxx/include/cmath:638:9: error: '::signbit' has not been declared
 0:00.46  using ::signbit;
 0:00.46          ^
 0:00.46 /home/makoto/bin/android-ndk-r12b/sources/cxx-stl/llvm-libc++/libcxx/include/cmath:639:9: error: '::fpclassify' has not been declared
 0:00.46  using ::fpclassify;
 0:00.46          ^
 0:00.46 /home/makoto/bin/android-ndk-r12b/sources/cxx-stl/llvm-libc++/libcxx/include/cmath:640:9: error: '::isfinite' has not been declared
 0:00.46  using ::isfinite;
 0:00.46          ^
 :
 :

Although we define _XOPEN_SOURCE=500 to use nl_langinfo(CODESET), but nsAndroidCharset.cpp doesn't call it.
Blocks: Fennec-ARM64
After landing bug 1345762, we don't define it when compiling OSPreferences_android.cpp. dup of bug 1345762.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345762
You need to log in before you can comment on or make changes to this bug.