checksetup.pl fails with Undefined symbol "mysql_real_escape_string"

VERIFIED WORKSFORME

Status

()

Bugzilla
Installation & Upgrading
P3
normal
VERIFIED WORKSFORME
16 years ago
5 years ago

People

(Reporter: dan, Assigned: zach)

Tracking

2.14.1
x86
FreeBSD

Details

(Reporter)

Description

16 years ago
When checksetup.pl is run, The following error occurs:
Checking user setup ...
Adding group tweakparams ...
/usr/libexec/ld-elf.so.1: /usr/lib/perl5/site_perl/5.6.1/i386-
freebsd/auto/DBD/mysql/mysql.so: Undefined symbol "mysql_real_escape_string"

I have reinstalled DBD::mysql -
DBD::mysql (v1.2209) ok: found v2.1011

I am running the following version of perl:
 v5.6.1 built for i386-freebsd
That looks like the mysql DBI module is finding a different version of mysql.so
than you built it against.

what does 'ldd
/usr/lib/perl5/site_perl/5.6.1/i386-freebsd/auto/DBD/mysql/mysql.so' report? Is
it pointing to the correct mysql.so from your mysql installation?
(Assignee)

Comment 2

16 years ago
I am 99% sure this isn't our fault, so downgrading down from blocker so it 
doesn't trip my "Really Bad Thing" queries.
Severity: blocker → normal
Priority: -- → P3
Target Milestone: --- → Future
(Assignee)

Comment 3

15 years ago
Reporter: please let us know if this issue has been resolved or if you are still
getting the error message. I (nor anyone else I know) cannot reproduce this error. 
(Assignee)

Comment 4

15 years ago
->worksforme
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Actually, DBD::mysql doesn't support MySQL older than 3.23 anymore. 
"mysql_real_escape_string" was added in Mysql 3.23, and DBD::mysql requires the
presense of that symbol as of v2.1001, which means any DBD::mysql newer than
2.1001 will require MySQL 3.23 or newer.  You'll get that error if you try to
run it against MySQL 3.22.x, even if you did compile it against that version. 
But yes, this is an issue with DBD::mysql and not with Bugzilla, so verifying
worksforme.
Status: RESOLVED → VERIFIED
mass clearing milestone on DUPLICATE/WONTFIX/WORKSFORME/INVALID so they'll show
up as untriaged if they get reopened.
Target Milestone: Future → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.