Revert stub installer default from 64-bit to 32-bit on Aurora 53

RESOLVED FIXED

Status

()

defect
P1
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: mhowell)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 wontfix, firefox52 wontfix, firefox53 fixed, firefox54 wontfix)

Details

Attachments

(1 attachment)

We must postpone our 64-bit rollout from Firefox 53 to 54 because Farmville 2 will be broken on 64-bit without async drawing (bug 1317995), but we can't enable async drawing until bug 1323403 and bug 1336517 are fixed. So we must revert 53's stub installer default from 64-bit to 32-bit.

Romain will ask Bryan Clark if we should revert in Aurora 53 or whether we can wait until Beta 53 (so we get more Aurora users testing 64-bit, even though we know it has some Flash bugs).
Given the low number of new users on Aurora when compared to the existing Win64 population on Aurora, keeping Win64 as default won't bring much testing value and the right approach is to avoid known bugs on Aurora. Bryan agrees, let's revert the stub default from 64 to 32 bit until the async drawing issue is fixed.
@ Romain: thanks for discussing with Bryan. I agree we should revert the installer default on Aurora. One might make the same argument for Nightly until we fix the async drawing bugs, but I don't think we should change Nightly installer's default for now.

@ Matt: can you please post a patch to change the 53 stub installer's default architecture from 32-bit to 64-bit?
Status: NEW → ASSIGNED
Flags: needinfo?(mhowell)
This patch disables 64-bit as the default for new installs, but leaves the option in place to select it manually.
Flags: needinfo?(mhowell)
Attachment #8837308 - Flags: review?(robert.strong.bugs)
Attachment #8837308 - Flags: review?(robert.strong.bugs) → review+
Comment on attachment 8837308 [details] [diff] [review]
Disable 64-bit as default for new installs

Approval Request Comment

[Feature/Bug causing the regression]:
See comment 0

[User impact if declined]:
Misbehavior or outright failure of popular Flash applications

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
No, it's not intended for or needed on nightly

[Needs manual test from QE? If yes, steps to reproduce]:
No, I've tested it manually

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
It's a very small and focused change, and I've manually verified it

[String changes made/needed]:
None
Attachment #8837308 - Flags: approval-mozilla-aurora?
Comment on attachment 8837308 [details] [diff] [review]
Disable 64-bit as default for new installs

Agreed, let's disable on aurora since we will need to delay release till 54.
Attachment #8837308 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Matt reverted the installer default in Aurora 53.
Summary: Revert stub installer default from 64-bit to 32-bit (TBD: on Aurora 53 or Beta 53?) → Revert stub installer default from 64-bit to 32-bit on Aurora 53
Blocks: 1342347
You need to log in before you can comment on or make changes to this bug.