too many matches in generated code prevent me from seeing the non-generated callers of CheckedUnwrap

RESOLVED FIXED

Status

Webtools
Searchfox
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: bholley, Assigned: billm)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
In [1], I'm trying to find all the callers of CheckedUnwrap. Unfortunately, there are more than 1000 hits in generated code, after which point searchfox gives up. I'm not sure whether this is a runtime or parse-time limitation, but I don't see a way to ask for more results.

As a mitigation, it would be nice if generated code were indexed last, since generated results are, on balance, more verbose and less useful.


[1] http://searchfox.org/mozilla-central/search?q=symbol:_ZN2js13CheckedUnwrapEP8JSObjectb&redirect=false
This was a regression from a while ago. Fixed in https://github.com/bill-mccloskey/searchfox/commit/f8f8f31129f8551fcdcb781cb6c0454789d95923.
Assignee: nobody → wmccloskey
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Comment 2

a year ago
Thanks bill!
You need to log in before you can comment on or make changes to this bug.