Closed Bug 1338655 Opened 3 years ago Closed 3 years ago

mp4parse rust bindings no longer compile with cargo from Rust Nightly 2017-02-10

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: qdot, Assigned: rillian)

References

Details

Attachments

(1 file)

Due to a Cargo patch landing that now automatically includes build.rs files regardless of commands in Cargo.toml, the build.rs for mp4parse-capi is included in the build. Since the cheddar crate wasn't vendored in, we can't find it, and get a build error.
Summary: mp4parse rust bindings no longer compile under rust 1.17 (Rust Nightly 2017-02-10) → mp4parse rust bindings no longer compile with cargo from Rust Nightly 2017-02-10
Thanks for the report! Per irc discussion, now that we've vendored syntex, I'll just go ahead and vendor cheddar and stop patching out the build-depends line, assuming that doesn't confuse anything. Fallback is to patch out build.rs, since cargo is apparently auto-detecting it now.
Assignee: nobody → giles
This seems to be https://github.com/rust-lang/cargo/issues/3391 which suggests we can also patch in `build = false` in Cargo.toml. That would be a better solution if we aren't able to use the generated header.

Going forward, Ted suggested we hack (unmaintained) cheddar to use syn instead of syntex for the build-time speed advantage.
We're not currently building syntex, so keeping the header generation at import time seems better here.
Comment on attachment 8836216 [details]
Bug 1338655 - Don't try to build mp4parse bindings.

https://reviewboard.mozilla.org/r/111682/#review113446
Attachment #8836216 - Flags: review?(nfroyd) → review+
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/acfa7cfcb32b
Don't try to build mp4parse bindings. r=froydnj
https://hg.mozilla.org/mozilla-central/rev/acfa7cfcb32b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Duplicate of this bug: 1339162
FYI, for me, it doesn't build with build=false, see bug 1340594.

Maybe the change you've landed depends on specific tool versions, and either the build should check for those versions, or somehow that file needs to be parameterized?
See Also: → 1340594
Depends on: 1340594
See Also: 1340594
(In reply to Jorg K (GMT+2) from comment #10)
> THUNDERBIRD_52_VERBRANCH:
> https://hg.mozilla.org/releases/mozilla-esr52/rev/
> 21af4e17cbf9f225e99c4103ac73a72311a702d1

It was backed out:
https://hg.mozilla.org/releases/mozilla-esr52/rev/c3c8a7968114
You need to log in before you can comment on or make changes to this bug.