Add error tests for managees being stronger than managers

RESOLVED DUPLICATE of bug 1338594

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 1338594
a year ago
a year ago

People

(Reporter: mccr8, Assigned: mccr8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a year ago
Protocols can declare send semantics and nesting, and there is code in CheckTypes::visitProtocol to check that if protocol PFoo is managed by PBar, then PFoo is not stronger than PBar. However, we don't have any IPDL unit tests for these conditions.
(Assignee)

Comment 1

a year ago
I just added these to my patch in bug 1338594.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1338594
You need to log in before you can comment on or make changes to this bug.