WebExtensions must contain API for file system IO

RESOLVED DUPLICATE of bug 1246236

Status

()

Toolkit
WebExtensions: General
RESOLVED DUPLICATE of bug 1246236
a year ago
a year ago

People

(Reporter: fdsc, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

The access to the file system is extremely important for debugging release versions of add-ons or distribute add-ons settings with the test addons.


Actual results:

The error message (in addition) from users could previously be accompanied by the installation of a test version of add-ons on their browsers with the same addon id and settings. When this extension was completely identical to the behavior when starting the browser (which not provides about:debugging).

Now its prevents the need for using signature add-ons.
So looking for other ways to debug.


Expected results:

USE CASE 1
1. The user should be able to provide detailed logs if he gets an error and developer cannot be repeated.
2. A developer wants get full user setting the additions. It is easiest to implement if it's possible to export the settings to the file.

USE CASE 2
It is possible to transfer add-on settings between different versions of the add-on or between different user profiles (to set up similar profiles).
(Reporter)

Updated

a year ago
Blocks: 1215059
(Reporter)

Updated

a year ago
Alias: want-File.IO
Summary: (want File.IO) WebExtensions must contain API for file system IO → WebExtensions must contain API for file system IO

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1246236
Alias: want-File.IO
You need to log in before you can comment on or make changes to this bug.